Opened 5 years ago

Closed 5 years ago

#1594 closed defect (fixed)

Error in global page when bringing up contextmenu for blocked frame on Safari

Reported by: sebastian Assignee: sebastian
Priority: P4 Milestone: Adblock-Plus-1.8.8-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/6465209950535680

Description

Environment

Safari 8

How to reproduce

  1. Go to Options -> General
  2. Disable "Show 'Block Element' right-click menu item"
  3. Load any website with blocked <iframe>elements, e.g. https://thepiratebay.se/search/Debian/0/99/0
  4. Right click on the blocked frame

Observed behaviour

There is no user visible affect, however if you inspect the extension's global page, you see an error being logged. That is because the content script's contextmenu event handler isn't called, and therefore event.userInfo is undefined in the global page.

Expected behaviour

The event handler in the global page should properly handle that case, without producing any errors.

Change History (2)

comment:1 Changed 5 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 5 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.