Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1603 closed defect (fixed)

"Block element" does not work when page cancels click event

Reported by: passbrains Assignee: sebastian
Priority: P3 Milestone: Adblock-Plus-1.8.8-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/6224757330542592

Description (last modified by sebastian)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=AOP-136

Environment

Windows + Vista 64bit + Chrome/Opera + English
ABP version Adblock Plus Version 1.8.7.1254

How to reproduce

  1. Install ABP extension on Opera.
  2. Load website  http://www.viber.com/#windowsphone

3, Try to block javascript active menu as shown by red circle in attached image.

Observed behaviour

Not able to block the selected item as 'Add filter' pop-up does not appear.
Instead due to active menu, on clicking it navigates.

Expected behaviour

Shall be able to block the selected item i.e. javascript active menu.

Attachments (1)

3668_1416585931_viber.jpg (91.5 KB) - added by passbrains 5 years ago.

Download all attachments as: .zip

Change History (6)

Changed 5 years ago by passbrains

comment:1 Changed 5 years ago by sebastian

  • Component changed from Unknown to Platform
  • Description modified (diff)
  • Owner set to sebastian
  • Platform changed from Opera to Unknown
  • Priority changed from Unknown to P3
  • Ready set
  • Summary changed from Unable to block Active menu with javascript to "Block element" does not work when page cancels click event

comment:2 Changed 5 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

The problem here is that the page's click event handler cancels the event, so our event listener isn't called. To mitigate issues like that we should register our event with the capturing phase.

comment:3 Changed 5 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:5 Changed 5 years ago by sebastian

Also see #1636

Note: See TracTickets for help on using tickets.