Opened 5 years ago

Closed 5 years ago

#1607 closed defect (fixed)

"Block element" injects overlays with wrong z-index

Reported by: passbrains Assignee: sebastian
Priority: P4 Milestone: Adblock-Plus-1.8.8-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/4605237906112512

Description (last modified by sebastian)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=AOP-119

Environment

Windows + Vista 64bit + Opera + English
ABP version Adblock Plus Version 1.8.7.1253

How to reproduce

  1. Install ABP extension on Opera.
  1. Open website

http://www.flipkart.com/
 
3.click on "signup".
A popup window will appear.

  1. Try to block Facebook, Google, X elements.
  2. Observe.

Observed behaviour

Not able to block Facebook, Google, X elements, because back ground elements getting selected to block.
See attached screen shot.

Expected behaviour

Should be able to block Facebook, Google, X elements.

Attachments (1)

3668_1416060227_flipkart1.jpg (106.6 KB) - added by passbrains 5 years ago.

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by passbrains

comment:1 Changed 5 years ago by sebastian

  • Component changed from Unknown to Platform
  • Description modified (diff)
  • Owner set to sebastian
  • Platform changed from Opera to Unknown
  • Priority changed from Unknown to P4
  • Ready set

comment:2 Changed 5 years ago by sebastian

  • Status changed from new to reviewing
  • Summary changed from Not able to block Facebook,Google elements. to "Block element" injects overlays with wrong z-index

That is because the overlay we inject for the image below the login dialog, uses a higher z-index than that dialog. The overlays should always use the same z-index as element they were created for, to make sure that they are positioned over that element, but below other elements with higher z-index.

comment:3 Changed 5 years ago by sebastian

  • Review URL(s) modified (diff)

comment:4 Changed 5 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.