Opened 5 years ago

Closed 5 years ago

#1610 closed defect (fixed)

"Block element" removes overlays while dialog still shows

Reported by: sebastian Assignee: sebastian
Priority: P3 Milestone: Adblock-Plus-1.8.8-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/4923599135703040

Description

How to reproduce

  1. Go to http://9gag.com
  2. Click ABP icon
  3. Choose element
  4. Select an image

Observed behaviour

The dialog shows up, but the selected image isn't highlighted anymore. That is because the overlays (used to highlight images, frames, Flash, etc.) are removed when the dialog shows. Other elements are still highlighted until the dialog closes, however.

Expected behaviour

All elements should be highlighted until the dialog closes.

Change History (2)

comment:1 Changed 5 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 5 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.