Opened 5 years ago

Closed 5 years ago

#1611 closed defect (fixed)

Inconsistent behavior with "Block element" context menu item

Reported by: sebastian Assignee: sebastian
Priority: P3 Milestone: Adblock-Plus-1.8.9-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/6236888415338496

Description (last modified by sebastian)

How to reproduce

  1. Go to ​http://adventagegroups.com/Index.aspx
  2. Wait till the image placeholder appears
  3. Right-click on image
  4. Choose "Block element"

Observed behaviour

The dialog doesn't show up. That is because since the image didn't load the context menu API doesn't provide a URL. However, when you use "Block element" form the popup UI the dialog shows up and suggests a filter based on the elements src attribute.

Expected behaviour

The behavior should be the same, regardless whether "Block Element" from the context menu or popup UI has been used, always generating all relevant filters.

Change History (4)

comment:1 Changed 5 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 5 years ago by sebastian

  • Description modified (diff)

Copied steps to reproduce from #1627, to point out that this issue can already be reproduced.

The intial issue description were about how multiple URLs considered with #1601, wouldn't be considered with "Block element" from the context menu, which is another scenario to reproduce the same issue.

comment:3 Changed 5 years ago by sebastian

  • Description modified (diff)

comment:4 Changed 5 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.