Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#1612 closed defect (fixed)

"Block element" removes overlay instead actual element

Reported by: passbrains Assignee: sebastian
Priority: P3 Milestone: Adblock-Plus-1.8.8-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/6500163518464000

Description (last modified by sebastian)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=AOP-147

Environment

Windows + Vista 64bit + Chrome/Opera + English
ABP version Adblock Plus Version 1.8.7.1256

How to reproduce

  1. Install ABP extension on Opera.
  1. Load website  http://9gag.com/gif
  2. See the video is playing in loop.
  3. Right click on video and block element.
  4. Filter added would be :
img-9gag-ftw.9cache.com/photo/a3d8d5r_460svwm.webm
  1. Observe.

 

Observed behaviour

Video content does not get blocked and keep playing though filter was added successfully.

Expected behaviour

Added filter content shall be blocked.

Attachments (1)

3668_1416936667_video.jpg (126.4 KB) - added by passbrains 4 years ago.

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by passbrains

comment:1 Changed 4 years ago by sebastian

  • Component changed from Unknown to Platform
  • Description modified (diff)
  • Owner set to sebastian
  • Priority changed from Unknown to P3
  • Ready set
  • Summary changed from Video content does not gets blocked though filter is added. to "Block element" removes overlay instead actual element

That is because the overlay instead its prisoner is removed.

comment:2 Changed 4 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:3 Changed 4 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:4 Changed 4 years ago by sebastian

  • Description modified (diff)
  • Platform changed from Opera to Unknown
Note: See TracTickets for help on using tickets.