Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1634 closed defect (fixed)

ABP for IE dev build v1.2.727 - ieframe crash

Reported by: mapx Assignee: sergz
Priority: P2 Milestone: Adblock-Plus-for-Internet-Explorer-1.3
Module: Adblock-Plus-for-Internet-Explorer Keywords:
Cc: oleksandr, sergz Blocked By:
Blocking: Platform: Internet Explorer
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/6585196354732032/

Description

Environment

IE 8
ABP 1.2.727

How to reproduce

visit lot of sites (for example rivals.com as reported by a user on forum)

It's the same error a lot of users reported with the stable ABP 1.2

I have no problems using 1.2.715 or 1.2.723, it seems to be a regression

Change History (11)

comment:1 Changed 5 years ago by oleksandr

  • Cc sergz added
  • Priority changed from Unknown to P2
  • Ready set

comment:2 Changed 5 years ago by oleksandr

Reproducible on Windows 8.1 x64 IE11 as well.

comment:3 Changed 5 years ago by mapx

weird ... I downgraded to 1.2.723 (uninstalling 727, installing then 723) and the ieframe error is still there ( bing.com, rivals.com ...)

could be some settings / files are not deleted when uninstalling ?!

all in windows xp

Last edited 5 years ago by mapx (previous) (diff)

comment:4 Changed 5 years ago by oleksandr

  • Owner set to sergz

comment:5 Changed 5 years ago by sergz

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:6 Changed 5 years ago by sergz

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:7 Changed 5 years ago by mapx

I tested 1.2.731, it's even worse for me.
I uninstalled 727, cleaned (using ccleaner) the registry, deleted the json file in the profile's folder (keeping only the list), installed 731, cleaned the cache / cookies ...

Now, whatever site I visit I'm getting the ieframe crap.

Last edited 5 years ago by mapx (previous) (diff)

comment:8 Changed 5 years ago by mapx

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:9 Changed 5 years ago by oleksandr

@mapx The issue is fixed in 1.2.733. Will be included in the next devbuild. Thanks for reporting this!

comment:10 Changed 5 years ago by oleksandr

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:11 Changed 5 years ago by fhd

  • Milestone set to Adblock-Plus-for-Internet-Explorer-1.3
Note: See TracTickets for help on using tickets.