Opened 5 years ago

Closed 5 years ago

Last modified 2 months ago

#1636 closed defect (duplicate)

Button blocking behavior is improper

Reported by: passbrains Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: greiner, sebastian Blocked By:
Blocking: Platform: Opera
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description (last modified by sebastian)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=AOP-134

Environment

Windows + Vista 64bit + Opera + English
ABP version Adblock Plus Version 1.8.7.1254

How to reproduce

  1. Install ABP extension on Opera.
  2. Load website

http://education-portal.com/academy/lesson/what-is-organizational-behavior-definition-and-history-of-the-field.html#lesson

  1. Block the Like "Yes" and "No" buttons one after other as shown in image1.
  2. Filter added would be

education-portal.com##.idislike.uplike
education-portal.com##.ilike

  1. Refresh the page.
  2. Observe the buttons.

 

Observed behaviour

Only "Yes" button is blocked but  "No" button is NOT blocked.
See image2.

Expected behaviour

Both  "Yes" and "No" buttons  shall be blocked.

Attachments (3)

3668_1416497156_edu1.jpg (143.1 KB) - added by passbrains 5 years ago.
3668_1416497156_edu2.jpg (142.7 KB) - added by passbrains 5 years ago.
3668_1417015244_buttons.jpg (140.9 KB) - added by passbrains 5 years ago.

Download all attachments as: .zip

Change History (11)

Changed 5 years ago by passbrains

Changed 5 years ago by passbrains

Changed 5 years ago by passbrains

comment:1 Changed 5 years ago by passbrains

1 - 26 Nov 2014 12:55:35 posted by Sebastian Noack
Those buttons doesn't exist anymore on that website.

2 - 26 Nov 2014 15:18:37 posted by Garima Agrawal
Dear Sebastian,

I am able to see those buttons still. Attaching snapshot.

Please check.

Rgds
Garima

3 - 28 Nov 2014 18:18:55 posted by Thomas Greiner
The reason why Sebastian and me cannot see it is because they are showing a different page design to us. In a different browser session, however, I was able to get the one shown in the screenshots which allowed me to reproduce the issue.

The issue is that the page's click listener is triggered and modifies the underlying element which causes the extension to create a suboptimal filter.

comment:2 follow-up: Changed 5 years ago by sebastian

  • Cc greiner sebastian added
  • Description modified (diff)

If I understand you correctly, this should be fixed with #1603, which moves our event handlers to the capturing phase. Unfortunately I still don't get those buttons, not even when using an incognito session.

comment:3 in reply to: ↑ 2 Changed 5 years ago by greiner

Replying to sebastian:

If I understand you correctly, this should be fixed with #1603, which moves our event handlers to the capturing phase.

Yes, presumably, that should fix this issue too because the issue is that the page's event handler is triggered before ours.

Unfortunately I still don't get those buttons, not even when using an incognito session.

I got that other design by switching to a different Chrome profile.

Last edited 5 years ago by sebastian (previous) (diff)

comment:4 Changed 5 years ago by sebastian

Well, #1603 is already fixed. So if you can reproduce the issue with the devbuild, it's something else.

comment:5 Changed 5 years ago by greiner

  • Resolution set to fixed
  • Status changed from new to closed

Right, I can confirm that.

comment:6 Changed 5 years ago by sebastian

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:7 Changed 5 years ago by sebastian

  • Resolution set to duplicate
  • Status changed from reopened to closed

Since this is the same issue as fixed by #1603, the reolution should be duplicate.

comment:8 Changed 7 months ago by Himanshu0709

spam

Last edited 2 months ago by kzar (previous) (diff)
Note: See TracTickets for help on using tickets.