Opened 5 years ago

Closed 5 years ago

#1644 closed defect (fixed)

<input type=image> elements are recognized with the wrong type on Safari

Reported by: sebastian Assignee: sebastian
Priority: P4 Milestone: Adblock-Plus-1.8.9-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5698232457887744

Description

Environment

Safari

How to reproduce

  1. Go to options
  2. Add custom filter: ||www.aweber.com/images/forms/sign-up-below/small-red/button.png^$image
  3. Go to ​http://www.softwaretestinghelp.com

Observed behaviour

The "Sign In" button isn't blocked. That is because the filter is limited to images with the $image filter option, but <input type=image> elements are reported with the type other instead.

Expected behaviour

<input type=image> elements should be reported with the type image (as they are on Chrome), matching filters using the $image filter option. So the "Sign In" button should be blocked here.

Change History (2)

comment:1 Changed 5 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 5 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.