Opened 5 years ago

Closed 5 years ago

#1647 closed defect (rejected)

Auto selection of "EasyList" where "EasyList Germany + EasyList" should be the default

Reported by: jobp Assignee:
Priority: Unknown Milestone:
Module: Core Keywords:
Cc: Blocked By:
Blocking: Platform: Android
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description (last modified by jobp)

Environment

Device: Nexus 5, rooted
OS: CM 11-20141008-SNAPSHOT-M11-hammerhead
ABP: Version 1.2.1 build# 347

How to reproduce

  1. Be in Germany, or have a German VPN
  2. Install Adblock Plus from ​https://adblockplus.org/devbuilds/adblockplusandroid/00latest.apk
  3. If you check the settings, you'll see "EasyList" enabled

Observed behaviour

EasyList is the default filterlist subscription

Expected behaviour

EasyList Germany + EasyList should be the default filterlist subscription

Change History (4)

comment:1 Changed 5 years ago by jobp

How is the filterlist selected? Is it device location or language? If the latter, then feel free to close it as "Invalid", because the Nexus 5 is configured in English.

comment:2 Changed 5 years ago by jobp

  • Component changed from Adblock-Plus-for-Android to Unknown
  • Milestone Adblock-Plus-for-Android-1.3 deleted
  • Platform changed from Unknown to Android

comment:3 Changed 5 years ago by jobp

  • Description modified (diff)

comment:4 Changed 5 years ago by greiner

  • Component changed from Unknown to Core
  • Resolution set to rejected
  • Status changed from new to closed

Indeed, the default filter list is chosen based on the application's user interface language.

Note: See TracTickets for help on using tickets.