Opened 5 years ago

Closed 5 years ago

#1658 closed defect (fixed)

"Block element" adds semicolon to style attributes

Reported by: passbrains Assignee: sebastian
Priority: P4 Milestone: Adblock-Plus-1.8.9-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5744307206094848

Description (last modified by sebastian)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=AOP-157

Environment

ABP version Adblock Plus Version 1.8.7.1271

How to reproduce

Pre-conditions :

  1. ABP Extension is installed on Opera Desktop Browser.
  2. ABP  is enabled. Check ABP version as  1.8.7.1271
  3. ABP Options :  Easylist = Enabled,  No filters added, Whtielisted domains = Empty, 

Show 'Block Element' right-click menu item = Checked,
Hide placeholders of blocked elements = Uncheked.

Steps :

  1. Go to http://www.xmlfiles.com/examples/tryit.asp?filename=note
  2. Block the left side textarea. as shown in pink in snapshot1

Filter added would be :
www.xmlfiles.com##textarea[style="width: 100%; height: 90%;"]

  1. textarea would be blocked.
  2. refresh the page. Observe.

Observed behaviour

On refresh blocked textarea reappears.

Expected behaviour

Blocked element shall not appear again on refresh.

Attachments (1)

3659_1417370122_xmlf1.jpg (57.0 KB) - added by passbrains 5 years ago.

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by passbrains

comment:1 Changed 5 years ago by sebastian

  • Cc sebastian added
  • Component changed from Unknown to Platform
  • Description modified (diff)
  • Platform changed from Opera to Unknown
  • Priority changed from Unknown to P4
  • Ready set
  • Summary changed from Block element does not work well on textarea to "Block element" adds semicolon to style attributes

The style attribute in the generated element hiding filter has a trailing semicolon, while the style attribute of the element didn't have a trailing semicolon, before it was selected. That is because we add additional styles to the element in order to highlight it, and when removing those styles, Chrome preserves a trailing semicolon.

comment:2 Changed 5 years ago by sebastian

  • Cc sebastian removed
  • Owner set to sebastian

comment:3 Changed 5 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:4 Changed 5 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.