Opened 5 years ago

Closed 5 years ago

#1661 closed defect (rejected)

Domain with rules mentioned in Whitelisted options should not be removed on enabling the ABP for the site where the rule is applicable

Reported by: kvthganesan Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: sebastian Blocked By:
Blocking: Platform: Safari
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

OS Version: 10.9.5 ; Safari 7.1; tested version: 1.8.8.1278

How to reproduce

  1. Go to Adblock Plus Options --> Whitelisted domains --> enter the domain *testing*.com
  1. Open the two urls which the name *testing* in the url

say weekendtesting.com
Crowdsourcedtesting.com

  1. Go to the url crowdsourcedtesting.com and Click on Enabled on this site in ABP

...

Observed behaviour

  1. Domain value with "*testing*" in the Adblock Plus Options --> Whitelisted options is removed
  2. ABP is enabled on both sites weekendtesting.com and crowdsourcedtesting.com

Expected behaviour

  1. Domain value with "*testing*" in Adblock Plus Options --> Whitelisted options should not be removed
  2. I have enabled ABP only on Crowdsourcedtesting.com and not in the weekendtesting.com (not even in the filter), so i am not expecting the ABP working on the sites which i have not enabled.

Change History (2)

comment:1 Changed 5 years ago by mapx

  • Cc sebastian added

comment:2 Changed 5 years ago by sebastian

  • Resolution set to rejected
  • Status changed from new to closed

This is the intended behavior. When toggling "Disabled on this site", the exception rule whitelisting the current page is removed.

Note: See TracTickets for help on using tickets.