Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#1665 closed defect (fixed)

Mouse events handled by the page interferes with "Block element" functionality

Reported by: passbrains Assignee: greiner
Priority: P3 Milestone: Adblock-Plus-1.8.11-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: sebastian, greiner Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/6175313801248768/

Description (last modified by greiner)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=AOP-159

Environment

Windows + Vista 64bit + Opera + English
ABP version Adblock Plus Version 1.8.7.1271

How to reproduce

  1. Install ABP extension on Opera.
  2. Load website

http://birlacenter.com
 

  1. Try to block any Hover active menu item. For example block 'Hast Jyotish'  as shown in attached snapshot by red circle.
  2. Filter added would be :

birlacenter.com##.icon-left.hover.over.up.active

  1. Refresh the page

Observed behaviour

Blocked item would again appear on screen.

Expected behaviour

Blocked item shalll not appear on screen.

Attachments (1)

3668_1417447824_jy.jpg (98.5 KB) - added by passbrains 3 years ago.

Download all attachments as: .zip

Change History (9)

Changed 3 years ago by passbrains

comment:1 Changed 3 years ago by greiner

  • Cc sebastian added
  • Component changed from Unknown to Platform
  • Description modified (diff)

This issue is similar to #1636 in which the site added a class when clicking on the element. While that issue was resolved by fixing #1603 this one is not since the site adds a class upon hovering over the element.

Generally, the site shouldn't handle any onmouse* events since the user is interacting with our overlay and not with the site. Therefore I'd suggest catching those events.

comment:2 Changed 3 years ago by greiner

  • Cc greiner added

comment:3 Changed 3 years ago by sebastian

  • Platform changed from Opera to Unknown
  • Priority changed from Unknown to P3
  • Ready set

I agree with the suggested solution. Though this means that you can't expand JavaScript menus in order to block elements within those menus anymore. However, this behavior will be less unexpected than the side effects of not catching those events.

comment:4 Changed 3 years ago by greiner

  • Owner set to greiner

comment:5 Changed 3 years ago by greiner

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:6 Changed 3 years ago by greiner

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:7 Changed 3 years ago by sebastian

  • Milestone set to Adblock-Plus-1.8.11-for-Chrome-Opera-Safari

Please remember to set the milestone, when closing issues as fixed.

comment:8 Changed 3 years ago by sebastian

  • Summary changed from Hover active menu item does not get blocked to Mouse events handled by the page interferes with "Block element" functionality
Note: See TracTickets for help on using tickets.