Opened on 12/05/2014 at 08:48:03 PM

Last modified on 03/01/2015 at 09:38:38 AM

#1667 new defect

Adblock plus not working for android 5 (Lollipop) non root device

Reported by: VGib Assignee:
Priority: Unknown Milestone:
Module: Adblock-Plus-for-Android Keywords:
Cc: rjeschke, fhd, philll Blocked By:
Blocking: Platform: Android
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):



Android 5 Lollipop on Nexus 5
Adblock plus Version 1.2.1 build #347

How to reproduce

install adblock plus. Install the proxy for the wifi or the 4G.
No ads are block.

Observed behaviour

No ads are block

Expected behaviour

Ads are block

As no one open the bug, i'm openning it. Please let me know if a workaround or new version is available

Attachments (2)

TestObject_Logcat_LG_Nexus_4_E960_real_13-01-2015_04-55-10.txt (646.4 KB) - added by philll on 01/22/2015 at 10:18:31 AM.
Nexus7_ABP-crash_filterlist-download (613.2 KB) - added by philll on 01/22/2015 at 10:21:35 AM.

Download all attachments as: .zip

Change History (24)

comment:1 Changed on 12/08/2014 at 04:12:54 PM by philll

Works fine for me with a Nexus 7 and Lollipop with the same ABP version.

comment:2 Changed on 01/03/2015 at 02:17:59 PM by elnator

ABP does not work on a non-rooted nexus, of any kind, running lollipop. The software 'runs' but it does not block adds at all. Has a constant state of 'waiting for traffic on port 2020'. You will occasionally get it bugged where it claims it's blocking traffic but it is not.

The problem is that the iptables in addblock are incorrect for lollipop:

This is an easy fix, just recompile iptables with PIE. Should take 5 mins, please issue an update for lollipop.

(Rooted users are already doing this to fix their own devices)

Last edited on 01/03/2015 at 02:18:57 PM by elnator

comment:3 Changed on 01/05/2015 at 09:57:54 AM by philll

  • Cc rjeschke fhd added

@rjeschke: Can you please look into this any time soon?

comment:4 Changed on 01/06/2015 at 09:22:41 AM by philll

  • Cc philll added

comment:5 Changed on 01/06/2015 at 09:53:54 AM by fhd

  • Component changed from Unknown to Adblock-Plus-for-Android
  • Owner set to fhd
  • Priority changed from Unknown to P1
  • Ready set

Yeah, I'll look into it. I've got some doubts this has anything to do with iptables though, since we don't even run it on non-rooted devices.

comment:6 Changed on 01/06/2015 at 04:41:31 PM by fhd

Looks like the real issue here is that is gone (apparerently replaced by ProxyInfo), so merely an API change, that appears to be the only problem in ABP 1.2.1. In the latest devbuild, there's also an issue with the new proxy configurators, most likely that's #1498, us checking for root access.

I don't think we want to wait for 1.3 with this, so I'll work on a patch for 1.2.1 tomorrow, that'll allow us to do a fix release making things work on Lollipop again.

Last edited on 01/06/2015 at 04:44:17 PM by fhd

comment:7 Changed on 01/07/2015 at 08:34:00 PM by rohitkishoregupta


comment:8 Changed on 01/08/2015 at 10:27:32 PM by fhd

  • Ready unset

Found some time to look into this properly now, and I cannot reproduce the problem.

I was chasing the wrong rabbit regarding ProxyProperties above - we recover from those exceptions just fine, works just fine on a Nexus 7 running 5.0.1 here.

The same goes for the devbuild, 1.3.347 works just fine for me.

Philip, you said you were able to reproduce this, right? How?

comment:9 Changed on 01/09/2015 at 07:05:56 PM by fhd

VGib, could you check what it says under "Filter subscription" in the ABP UI? Does it say "not loaded"? Does updating manually work?

comment:10 Changed on 01/17/2015 at 11:57:21 AM by jj


I can confirm the problem on a Nexus 4. Since the upgrade to Lollipop adblock stopped working. It still runs but it never updates its block list. Therefore some ads are still blocked but new ones not.

If I update manually then adblock crashes.

comment:11 Changed on 01/17/2015 at 12:54:27 PM by VGib

After 5.0.1 update and last adblock plus update; this seems to work for wifi.
But it still daesn't work for 4G internet.

I have in Filter subscription subscription: Liste FR + EasyList. (I'm french)

This was working with Android 4.4 KitKat and 4G.

I visit some of this website to check: or

Changed on 01/22/2015 at 10:18:31 AM by philll

Changed on 01/22/2015 at 10:21:35 AM by philll

comment:12 Changed on 01/22/2015 at 10:22:27 AM by philll

Filter lists couldn't be downloaded when I tested with a Nexus 4 and lollipop. I attached the log file. With a Nexus 7 on lollipop, updating the filter lists manually after the failed download reliably crashed Adblock Plus. Also attached that Nexus 7 log file.

comment:13 Changed on 02/14/2015 at 01:12:27 AM by markf

I just upgraded from KitKit to Lollipop on my HTC One M8.

ABP was a little flaky under KK (Internet connections for valid apps like FB and linkedin would randomly be unavailable), but ABP does not work at all on my device.

Following has been identified (before I uninstalled it):

  1. The hide icon does nothing...icon is still visible
  2. No ads are blocked
  3. Cannot update lists...ABP just crashes everytime.

ABP worked great for me on my HTC Sensation (ICS), and it would be great see have it working again on my One.


comment:14 follow-up: Changed on 02/14/2015 at 02:45:14 PM by xxKumquat

I have the same problem on the Galaxy s5 (unrooted.)
After updating to Android Lollipop(5.0) ABP says "waiting for traffic on port 2020" even though my settings are properly configured. I tried reinstalling with the dev-build for Android (354) and have had no success. I can update the Easylist w/o crashing on 354, however.

comment:15 Changed on 02/17/2015 at 01:33:13 PM by rjeschke

I ran some tests using the latest dev-build on some Android 5 devices:

  • started ABP
  • updated subscription
  • click on 'Hide icon'
  • Open Chrome, browse to to see if ads are blocked

These are the results:

Device           : Android : Blocks : Update :  Icon
Motorola Nexus 6 :  5.0.1  :  yes   :  yes   : partly
LG Nexus 5       :  5.0.1  :  yes   :  yes   : partly
HTC Nexus 9      :  5.0    :  yes   :  yes   : partly

partly in the icon column means, invisible icon but on the wrong position (not right-most), this is a known problem

So far I can not reproduce the bug that prevents ads from getting blocked. There is, though, an issue with the icon, as it only gets hidden (as it seems) when it gets updated to 'Ads are blocked on ...'. Will have a look into this soon.

Still, using our test devices I am not able to verify that ads are not blocked on Android 5. So we either need a S5 and a M8 here, or the log output from external devices.

Another thing: we will have to examine the 'Waiting for traffic' notification's behaviour again. It is possible that it gets fired on every start now, if the proxy could not be set from within ABP. Still, the notification should vanish after it really receives 'traffic', i.e. a request.

From my side, as I can not reproduce any serious bugs, and the rest is more or less cosmetics, we should really reduce the priority again to P2, except anybody is able to prove that build 354 still fails to block ads or fails on updating.

comment:16 Changed on 02/18/2015 at 03:23:48 PM by fhd

  • Owner fhd deleted

comment:17 Changed on 02/18/2015 at 03:28:17 PM by rjeschke

  • Priority changed from P1 to P2

comment:18 Changed on 02/18/2015 at 03:36:38 PM by philll

  • Priority changed from P2 to Unknown

We simply cannot reproduce this so far and can prove that this doesn't affect all lollipop users. Getting more debug output into our app is the best we can do for now on our end, but that is another story.

comment:19 Changed on 02/18/2015 at 07:35:34 PM by Sasqwatch

Pardon my ignorance, but is Adblock Plus supposed to stop ads in games? Things such as Candy Crush? The reason I ask is before the 5.0.1 update on my HTC M8 (sim free) AdB would update subscription lists and stop the ads. Now it does neither. On trying to update lists, the app crashes and then restarts without loading the lists.

comment:20 in reply to: ↑ 14 Changed on 02/20/2015 at 04:11:39 AM by xxKumquat

Replying to xxKumquat:

I have the same problem on the Galaxy s5 (unrooted.)
After updating to Android Lollipop(5.0) ABP says "waiting for traffic on port 2020" even though my settings are properly configured. I tried reinstalling with the dev-build for Android (354) and have had no success. I can update the Easylist w/o crashing on 354, however.

Retested with 355 development build. Adds are now blocked, and the proxy settings ARE detected by ABP. There is, however a confliction between the "Mobiwol no root firewall" app and ABP that was not present pre-lollipop. With Mobiwol, ABP still has the same problems stated previously.

comment:21 Changed on 02/20/2015 at 09:52:53 PM by rjeschke

@xxKumquat This can still be a problem of the Mobiwol firewall and might need a fix on their side, as it is using a VPN. We will try to debug these issues and see if we can do anything about this.

@Sasqwatch We are terribly sorry, but ABP does update subscriptions and block ads without crashing on our test devices. It would be really helpful if anybody could provide the logcat output from such a crash (using the latest development build -> build 354+).

comment:22 Changed on 03/01/2015 at 09:38:38 AM by Sasqwatch

Version 1.2.1 Build 355 works fine now, blocks ads and loads subscription.

Add Comment

Modify Ticket

Change Properties
as new .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from (none).
Next status will be 'reviewing'.
Note: See TracTickets for help on using tickets.