Opened 5 years ago

Closed 5 years ago

#1684 closed change (fixed)

Find some WIndows Firewal solution for the connection to the Windows remote debugger at testfabrik

Reported by: sergz Assignee: matze
Priority: Unknown Milestone:
Module: Office-IT Keywords:
Cc: philll, matze, oleksandr Blocked By:
Blocking: Platform: Unknown
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description (last modified by philll)

Background

Firstly, FYI http://support.microsoft.com/kb/948040 .

The starting point for remote debugging is http://msdn.microsoft.com/en-us/library/y7f5zaaa.aspx .
In general the process with the local virtual machine is

  • configure virtual machine network adapter to bridged adapter
  • install remote debugger monitor for our version of MS Visual studio on the virtual machine (I personally use MSVS2012 Update 4 and MSVS2013U4). One can download it from http://msdn.microsoft.com/en-us/library/bt727f1t.aspx
  • start remote debugger monitor
  • in visual studio choose "Debug"->"Attach to Process", then "Transport": "Default", then click "Find" and it very quickly finds this virtual machine (for example, IE10Win7:4016), click "select", enter credentials, now here is the list of process to which one can attach
  • choose the process and start debugging

With the remote debugger running at one of the Testfabrik machines, no instance was listed in the search results.

Feel free to ask any question and assistance.

What to change

Investigate the issue and find some local Windows firewall-based workaround.

Change History (6)

comment:1 Changed 5 years ago by philll

  • Description modified (diff)

comment:2 Changed 5 years ago by philll

  • Description modified (diff)

comment:3 Changed 5 years ago by matze

  • Owner set to matze

comment:4 Changed 5 years ago by matze

Requested VisualStudio license from @fhd, without I can't dig into that any further.

comment:5 Changed 5 years ago by philll

By Testfabrik:

Hello,

we have successfully attached to the remote debugger process on a VM where the remote debugger is running. This is how we have done this:

  • Connected and logged in as "adblockplus1" to the VM win-7-64-10-15 with the IP 192.168.100.18
  • Started the remote debugger on the remote VM which stated to run on the machine with the name and port WIN7641015:4018
  • Started Visual Studio 2013 on a windows VM running on a Mac
  • Clicked on TOOLS, the "Attach to process"
  • Entered the IP AND PORT as qualifier: "192.168.100.18:4018" and "Default" as Transport method.
  • Clicked on "Refresh"
  • Entered the username and according password in the authentication dialog.
  • Selected the debugger process with title "Visual Studio Remote Debugging Monitor"

I think one needs to enter the IP AND PORT to attach to the remote debugger.

comment:6 Changed 5 years ago by philll

  • Resolution set to fixed
  • Status changed from new to closed

The steps above could successfully be reproduced.

Note: See TracTickets for help on using tickets.