Opened 5 years ago

Closed 5 years ago

#1692 closed defect (fixed)

Dev builds can't be updated/installed

Reported by: scump Assignee:
Priority: P1 Milestone:
Module: Infrastructure Keywords:
Cc: sebastian, trev Blocked By:
Blocking: Platform: Safari
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

OS X 10.10.1, Safari 8.0.2, ABP dev build 1.8.8.1283, EasyList.

How to reproduce

I don't know if it's because of the Safari 8.0.2 update or the dev builds update, but since 1283, there's no way to update or install 1284, 1285 or any update of the dev build.

When installing the stable

http://s16.postimg.org/5vyyl2ged/Screen_Shot_2014_12_11_at_20_19_37.png

When installing the latest dev builds

http://s14.postimg.org/55hwo0b01/124j09v.png

And the weird thing is, when installing the stable version, it is shown as a dev build in Safari Extensions?

http://s7.postimg.org/tv5843l3v/Screen_Shot_2014_12_11_at_20_19_44.png

I had 1.8.8.1283 before the problem.

Change History (3)

comment:1 Changed 5 years ago by sebastian

  • Cc sebastian trev added
  • Priority changed from Unknown to P1
  • Ready set

Can reproduce this with Safari 8.0, even before updating to 8.0.2.

comment:2 Changed 5 years ago by sebastian

  • Component changed from Unknown to Infrastructure

It seems the devbuilds are signed with the old certificate again. :(

 $ xar -f ~/Downloads/00latest.safariextz --extract-certs certs
 $ openssl x509 -in cert00 -inform DER -dates -noout
notBefore=Nov  5 12:52:00 2013 GMT
notAfter=Nov  5 12:52:00 2014 GMT

comment:3 Changed 5 years ago by trev

  • Resolution set to fixed
  • Status changed from new to closed

Fixed. Also rebuilt Adblock Plus for Safari 1.8.8.1285 development build, the new one should be on the download servers shortly.

Note: See TracTickets for help on using tickets.