Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1694 closed defect (fixed)

Popup menu doesn't work when opening multiple tabs simultaneously on Safari

Reported by: sebastian Assignee: sebastian
Priority: P3 Milestone: Adblock-Plus-1.8.9-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: Blocked By:
Blocking: Platform: Safari
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5153060179410944

Description

Environment

Safari 8

How to reproduce

  1. Open the "View" menu
  2. Enable "Show favorites bar"
  3. Click a Category for the Favorites bar with multiple item (e.g. "News")
  4. Click "Open in tabs" (that means open all pages in that category)
  5. Click the ABP icon
  6. Click "Options"

Observed behaviour

Nothing happens.

Expected behaviour

The option page should be opened.

Change History (4)

comment:1 Changed 5 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

That is because the current tab get immediately replaced, hence SafariBrowserTab.browserWindow doesn't exist when isPageActive() is called, resulting into an error breaking the popup.

comment:2 Changed 5 years ago by philll

  • Platform changed from Unknown to Safari

comment:3 Changed 5 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:4 Changed 5 years ago by sebastian

  • Summary changed from Popup menu doesn't work when opening multiple tabs to Popup menu doesn't work when opening multiple tabs simultaneously on Safari
Note: See TracTickets for help on using tickets.