Opened 5 years ago

Closed 5 years ago

#1703 closed defect (fixed)

Element collapsing doesn't work for frames with javascript: URL

Reported by: sebastian Assignee: sebastian
Priority: P3 Milestone: Adblock-Plus-1.8.9-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: Blocked By: #1704
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5868615689568256

Description

Environment

Chrome 40 (and receptive Opera version)
Filter lists: EasyList + EasyList Germany + Acceptable Ads

How to reproduce

  1. Go to http://www.chip.de/downloads/Adblock-Plus-fuer-Firefox_22437623.html

Observed behaviour

You see placeholders for blocked frames, inside frames with javascript: URL. That is because due to Chrome bug 442107, load and error events aren't dispatched.

Expected behaviour

Placeholders for all elements that didn't load because Adblock Plus should be hidden.

Change History (4)

comment:1 Changed 5 years ago by sebastian

  • Summary changed from Element hiding and collapsing doesn't work for frames with javascript: URL to Element collapsing doesn't work for frames with javascript: URL

comment:2 Changed 5 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:3 Changed 5 years ago by sebastian

  • Blocked By 1704 added

comment:4 Changed 5 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.