Opened 5 years ago

Closed 5 years ago

#1705 closed defect (incomplete)

AdBlock Plus blocks elements in Chrome new tab extensions

Reported by: fede91it Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: sebastian, mapx, arthur Blocked By:
Blocking: Platform: Chrome
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

Windows 8.0
Chrome 39.0.2171.95 m (64-bit)
AdBlock Plus 1.8.8

EasyList Italy+EasyList
Malware Domains
EasyPrivacy
Fanboy's Social Blocking List

How to reproduce

  1. Install Chrome Muzli extension
  2. Set Muzli as default new tab handler
  3. Open new tab

Observed behaviour

Here, AdBlocks blocks a lot of element but I can't disable it for this specific page because I have no domain to insert in the exclusion option page.

I've tried to add the "domain" of the extension, that in case of chrome-extension://glcipcfhmopcgidicgdociohdoicpdfc/index.html is glcipcfhmopcgidicgdociohdoicpdfc, but has not taken effect.

Expected behaviour

Say to AdBlock to not block the new tab page.

Attachments (2)

before filter.PNG (2.2 KB) - added by fede91it 5 years ago.
after filter.PNG (1.5 KB) - added by fede91it 5 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 5 years ago by mapx

  • Cc sebastian mapx added
  • Component changed from Unknown to Platform

comment:2 Changed 5 years ago by sebastian

Adblock Plus doesn't block extension URLs. However, Adblock Plus might block third-party resources inside Chrome apps and extensions. But Muzli's new tab page looks the same for me with Adblock Plus enabled/disabled. So where exactly does Adblock Plus block elements there?

comment:3 Changed 5 years ago by fede91it

comment:4 Changed 5 years ago by mapx

I tested also and some elements are blocked
see also in the console:

empty

common.js:184 http://muz.li
common.js:441 5b59aedcebc994c945c0cae656d36625d5236c01123edfc833ad6e322a
https://stats.g.doubleclick.net/collect?t=dc&aip=1&v=1&_v=j31&tid=UA-53926383-1&cid=135422337.1418730534&jid=887727584&_u=cGAAgMQB~&z=818093733 Failed to load resource: net::ERR_TUNNEL_CONNECTION_FAILED
https://www.google.com/uds/?file=ads&v=3&packages=search&async=2 Failed to load resource: net::ERR_BLOCKED_BY_CLIENT
http://designezcom.fatcow.com/revive/www/delivery/avw.php?zoneid=4&n=0e8asdb870 Failed to load resource: net::ERR_BLOCKED_BY_CLIENT
chrome-extension://www.google.com/adsense/search/async-ads.js Failed to load resource: net::ERR_FAILED

comment:5 Changed 5 years ago by sebastian

I can't reproduce what you see in the screencast, because all the feeds are empty for me. Any idea how to change that?

But I can confirm that Adblock Plus blocks the requests, mapx has lsited. However, those are in fact advertising and tracking, and therefore Adblock Plus is supposed to block them.

comment:6 Changed 5 years ago by mapx

The real issue here seems to be: how can a user unblock that stuff ? (without whitelisting the filters for all the domains)

Last edited 5 years ago by mapx (previous) (diff)

comment:7 Changed 5 years ago by fede91it

Exactly mapx. I need to unblock the whole page, not single domains.

comment:8 Changed 5 years ago by sebastian

I think the problem here is that the Muzli new tab extension doesn't work properly with Adblock Plus. Disabling Adbock Plus there (which currently isn't possible) would just be a workaround. Users still need to figure out the problem and then have to manually fix it. So I think what's important here is to figure out which filters are causing that issue and fixing them in EasyList.

Letting users disable Adblock Plus on extension pages (the same way they currently can for real websites) would be a nice-to-have feature. However, after looking into it, this doesn't seem to be possible, or at least not trivial to implement, since Chrome idenitfies the top-level frame here as chrome://newtab and not by its actual chrome-extension:// URL.

comment:9 Changed 5 years ago by mapx

@fede, try adding

@@||designezcom.fatcow.com/revive/www/delivery


Last edited 5 years ago by mapx (previous) (diff)

comment:10 Changed 5 years ago by arthur

  • Cc arthur added

If you update "Fanboy's Social Blocking List" in about 15 minutes, you should see images in that feed again. Other that than everyting looks fine to me.

Changed 5 years ago by fede91it

Changed 5 years ago by fede91it

comment:11 Changed 5 years ago by fede91it

The only thing changed adding the filter is that I don't see the image broken icon.
See attachments. Fanboy's list updated.

comment:12 Changed 5 years ago by arthur

The changes probably were not live then, that's why I wrote "in about 15 minutes". Try updating it in 5 minutes again.

comment:13 Changed 5 years ago by sebastian

  • Resolution set to invalid
  • Status changed from new to closed

Closing as invalid because it wasn't a bug in Adblock Plus, but a filter list issue.

Note: See TracTickets for help on using tickets.