Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1712 closed defect (fixed)

Default subscription is set to "Adblock Warning Removal List" on FF mobile

Reported by: saroyanm Assignee: saroyanm
Priority: P2 Milestone: Adblock-Plus-2.6.7-for-Firefox
Module: Adblock-Plus-for-Firefox Keywords:
Cc: philll Blocked By:
Blocking: Platform: Firefox Mobile
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/4759471792324608/

Description

Environment

Devices: Nexus 4/7
Android version: 5.0
Firefox Versions: 31/34/35(Beta)
ABP versions: 2.6.6/2.6.6.3881
Android language: English (United States)

How to reproduce

  1. Navigate to Firefox settings page (Settings -> Apps -> Firefox)
  2. Click on "Clear Data" button
  3. Install Adblock Plus for Firefox mobile
  4. Navigate to Adblock Plus settings page
  5. See that default subscription is set to "Adblock Warning Removal List"
  6. Switch to Easylist
  7. Navigate to Adblock Plus settings page again
  8. See that subscription still is set to "Adblock Warning Removal List"
  9. Switch to other list (ex.: RuAdList+EasyList)
  10. Switch again to Easylist
  11. See that "Adblock Warning Removal List" is no more available in subscriptions list

Observed behaviour

As mentioned on 5-th point the subscription is set to "Adblock Warning Removal List" by default which looks to be wrong because the ads are being blocked, You can't switch to Easylist until you will not change to another subscription as mentioned in 9-11 points.

Expected behaviour

The subscription should be set to Easylist and "Adblock Warning Removal List" should not be available in the list.

Change History (5)

comment:1 Changed 5 years ago by saroyanm

  • Priority changed from Unknown to P2
  • Ready set

comment:2 Changed 5 years ago by saroyanm

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:3 Changed 5 years ago by saroyanm

  • Owner set to saroyanm

comment:4 Changed 5 years ago by saroyanm

  • Milestone set to Adblock-Plus-for-Firefox-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:5 Changed 5 years ago by philll

  • Platform changed from Firefox/Firefox Mobile to Firefox Mobile

Made Firefox and Firefox mobile available as seperate platforms.

Note: See TracTickets for help on using tickets.