Opened 5 years ago

Closed 5 years ago

#1725 closed defect (fixed)

Warnings and errors occur on several pages since PHP update

Reported by: mapx Assignee:
Priority: P1 Milestone:
Module: Infrastructure Keywords:
Cc: trev, sebastian, greiner Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working:
Review URL(s):

Description (last modified by mapx)

Environment

chrome 40, firefox 34,..

How to reproduce

open one of the topics on adblockplus.org/forum (ABP enabled / disabled no difference)

a lot of errors on the top of the page

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /srv/www/vhosts/adblockplus.org/phproot/forum/includes/bbcode.php on line 483

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /srv/www/vhosts/adblockplus.org/phproot/forum/includes/bbcode.php on line 483

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /srv/www/vhosts/adblockplus.org/phproot/forum/includes/bbcode.php on line 483

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /srv/www/vhosts/adblockplus.org/phproot/forum/includes/bbcode.php on line 483

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /srv/www/vhosts/adblockplus.org/phproot/forum/includes/bbcode.php on line 112

Strict Standards: Non-static method utf_normalizer::nfc() should not be called statically in /srv/www/vhosts/adblockplus.org/phproot/forum/includes/utf/utf_tools.php on line 1781

Strict Standards: Non-static method utf_normalizer::nfc() should not be called statically in /srv/www/vhosts/adblockplus.org/phproot/forum/includes/utf/utf_tools.php on line 1781

Change History (15)

comment:1 Changed 5 years ago by mapx

  • Description modified (diff)

comment:2 Changed 5 years ago by mapx

  • Component changed from Infrastructure to Websites

comment:3 Changed 5 years ago by sebastian

  • Cc sebastian added
  • Component changed from Websites to Infrastructure
  • Priority changed from Unknown to P1
  • Ready set

trev updated yesterday the PHP version, while trying to fix an issue with the website.

Another regression I noticed is that our blog doesn't work anymore, showing following error:

Parse error: syntax error, unexpected 'yield' (T_YIELD), expecting '(' in /srv/www/vhosts/adblockplus.org/phproot/textpattern/publish/taghandlers.php on line 322

comment:4 Changed 5 years ago by sebastian

  • Summary changed from forum errors to Blog is down and forum shows warnings since PHP update

comment:5 Changed 5 years ago by trev

For reference, I've renamed function yield() into _yield() (seems unused) and added the static keyword to timezone::is_dst() and timezone::is_supported() - only on the server, not in the repository. This was sufficient to get rid of the errors on the public pages. However, I think that we want to finally update Textpattern on the server.

comment:6 Changed 5 years ago by trev

I've also modified common.php in phpBB for now, changed error_reporting(E_ALL ^ (E_NOTICE | E_WARNING)); into error_reporting(E_ALL ^ (E_NOTICE | E_WARNING | E_DEPRECATED));. This seems to be the only way to suppress warnings (short of fixing them which would go too far).

comment:7 Changed 5 years ago by mapx

still this kind of warnings (when you post or modify a post):
Strict Standards: Non-static method utf_normalizer::nfc() should not be called statically in /srv/www/vhosts/adblockplus.org/phproot/forum/includes/utf/utf_tools.php on line 1781

Last edited 5 years ago by mapx (previous) (diff)

comment:8 Changed 5 years ago by trev

Modified it again to exclude E_STRICT as well.

comment:9 Changed 5 years ago by mapx

another warning here: https://adblockplus.org/en/subscriptions/

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /srv/www/vhosts/adblockplus.org/anwiki/_addons/contentclasses/contentclass_subscriptionlist/contentclass_subscriptionlist.tpl.php on line 36

comment:10 Changed 5 years ago by arthur

Also, all the screenshots e.g. on https://adblockplus.org/en/getting_started are not showing up.

comment:11 Changed 5 years ago by sebastian

Another PHP warning on https://share.adblockplus.org/:

Strict Standards: Declaration of AnwActionDefault_minimal::output() should be compatible with AnwActionPage::output($bEmergencyError = false) in /srv/www/vhosts/adblockplus.org/anwiki/_addons/actions/action_minimal/action_minimal.php on line 4

comment:12 Changed 5 years ago by sebastian

  • Summary changed from Blog is down and forum shows warnings since PHP update to Warnings and errors occur on several pages since PHP update

comment:13 Changed 5 years ago by innerself

There is another PHP warning on acceptableads.org. Also, the icons are not loading:

Strict Standards: Declaration of AnwActionDefault_minimal::output() should be compatible with AnwActionPage::output($bEmergencyError = false) in /srv/www/vhosts/adblockplus.org/anwiki/_addons/actions/action_minimal/action_minimal.php on line 4

comment:14 Changed 5 years ago by greiner

  • Cc greiner added

comment:15 Changed 5 years ago by trev

  • Resolution set to fixed
  • Status changed from new to closed

PHP was downgraded again. Now we know that we have to get rid of the legacy systems (particularly ones that notoriously set debugging flags) before attempting to update that system...

Note: See TracTickets for help on using tickets.