Opened 6 years ago

Closed 5 years ago

#173 closed defect (fixed)

Adblock Plus for IE does not respect $third-party in filters

Reported by: arthur Assignee: oleksandr
Priority: P2 Milestone: Adblock-Plus-1.2-for-Internet-Explorer
Module: Adblock-Plus-for-Internet-Explorer Keywords: ie_devbuild_1.2
Cc: Blocked By:
Blocking: Platform:
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/4842319220047872/

Description

Environment

Windows 8.1 x64
IE 11.0.9600.16521
Adblock Plus for IE 1.1
EasyList

How to reproduce

  1. Go to https://www.adcash.com/

Observed behaviour

All content is blocked there as if the filter would be

||adcash.com^

Expected behaviour

It should not be blocked due to the $third-party flag in the filter

||adcash.com^$third-party

Change History (11)

comment:1 Changed 6 years ago by philll

  • Priority changed from Unknown to P2

comment:2 Changed 6 years ago by oleksandr

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

The issue was not with the $third_party, but with request type detection. http://codereview.adblockplus.org/4842319220047872/ fixes it.

comment:3 Changed 6 years ago by philll

  • Ready set

comment:4 Changed 6 years ago by trev

  • Owner set to oleksandr

comment:5 Changed 6 years ago by arthur

Is this the same issue?

There is this whitelist

@@||ad3.eu^$~third-party

in EasyList to prevent blocking the whole page by this filter

/ad3.

Note the ~ in $~third-party which means the opposite what $third-party does (that the filter will be applied on first-party resources only).

comment:6 Changed 6 years ago by oleksandr

Seems like the issue remains and sometimes is still manifested even on adcash.com

comment:7 Changed 6 years ago by arthur

Have you also checked the issue with ad3.eu I mentioned?

comment:8 Changed 6 years ago by oleksandr

  • Milestone set to Adblock-Plus-for-Internet-Explorer-next

comment:9 Changed 5 years ago by oleksandr

The issue was actually fixed in the provided codereview and sites listed above are wokring ok. The fix was included into devbuilds since 1.2.635.

comment:10 Changed 5 years ago by philll

  • Keywords ie_devbuild_1.2 added

comment:11 Changed 5 years ago by oleksandr

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.