Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#1734 closed change (incomplete)

Enhanced tools for blocking advertisement with filter lists

Reported by: Sworddragon Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: arthur, mapx Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Verified working:
Review URL(s):

Description

Background

Being on EasyList + EasyPrivacy + EasyList Germany I'm noticing more and more ads on websites. I have made a request to EasyList Germany for a filter update but they have given up in some cases with the reason that the sites are applying an update within a short time (a few hours - 1 day).

What to change

If the websites are being able to counter the filter lists so fast I think the maintainers need better tools to block the advertising. The difficulty is to find the right one that is also practical. But i'm noticing that ads are normally open a related website if they are clicked (directly or over event handlers in JavaScript). This can be used as an advantage (for example by defining rules like "every object from site * that opens on a click someexampleads.com will be suppressed").

Change History (6)

comment:1 Changed 5 years ago by mapx

  • Cc arthur added
  • Resolution set to invalid
  • Status changed from new to closed

well, these are filter issues, add your own custom filters

for example you could add (see if works)

prosiebenmaxx.de##IMG[src*=".gif"]
||2mdn.net$object-subrequest,domain=prosiebenmaxx.de

comment:2 Changed 5 years ago by mapx

  • Cc mapx added

comment:3 Changed 5 years ago by arthur

#616 and #647 should help in that case.

comment:4 follow-up: Changed 5 years ago by Sworddragon

well, these are filter issues, add your own custom filters

Yes, it is a filter issue but just because the current tools from Adblock Plus are probably not enough and custom filters should not be the long-term goal.

#616 and #647 should help in that case.

From the information I have got the problem is that the websites are just manually countering updated filters too fast which has nothing to do with an automatic detection if the user uses an ad blocker. But correct me if I have missed something.

comment:5 in reply to: ↑ 4 Changed 5 years ago by arthur

Replying to Sworddragon:

From the information I have got the problem is that the websites are just manually countering updated filters too fast which has nothing to do with an automatic detection if the user uses an ad blocker. But correct me if I have missed something.

They don't detect whether an adblocker is present or not. They use resources which are being hidden and/or blocked by generic filters.

comment:6 Changed 4 years ago by philll

  • Platform changed from Firefox/Firefox Mobile to Firefox

Made Firefox and Firefox mobile available as seperate platforms.

Note: See TracTickets for help on using tickets.