Opened 4 years ago

Closed 4 years ago

#1741 closed defect (duplicate)

"Block element" dialog doesn't work while first run page is open

Reported by: passbrains Assignee:
Priority: P3 Milestone:
Module: Platform Keywords:
Cc: sebastian Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working:
Review URL(s):

Description (last modified by sebastian)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=ACH-94

Environment

Windows + 8 64bit + Chrome + English
ABP version 1.8.8.1292

How to reproduce

  1. Install Adblock Plus, and wait for the first run page to show up
  2. Open another page (e.g. www.timesofindia.com)
  3. Click ABP icon and click on 'Block element'. Select an element to be blocked.

Observed behaviour

"Block element" dialog shows up, but the text field showing the suggested filters is empty.

Expected behaviour

Filter should be generated and suggested for the selected element.

Attachments (2)

3766_1419853390_firstRun.png (192.4 KB) - added by passbrains 4 years ago.
3766_1419853390_AddFilterEmpty1.mp4 (1.6 MB) - added by passbrains 4 years ago.

Download all attachments as: .zip

Change History (4)

Changed 4 years ago by passbrains

Changed 4 years ago by passbrains

comment:1 Changed 4 years ago by sebastian

  • Cc sebastian added
  • Component changed from Unknown to Platform
  • Description modified (diff)
  • Platform changed from Chrome to Unknown
  • Priority changed from Unknown to P3
  • Ready set
  • Summary changed from Add Filters window always displays empty when click blocking element. to Add Filters dialog is broken after sharing on first run page

comment:2 Changed 4 years ago by sebastian

  • Description modified (diff)
  • Resolution set to duplicate
  • Status changed from new to closed
  • Summary changed from Add Filters dialog is broken after sharing on first run page to "Block element" dialog doesn't work while first run page is open

That is because the first run page responds to the clickhide-init message with an empty response, before the background page does. This is fixed when the default response is removed by #1708.

Note: See TracTickets for help on using tickets.