Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#1746 closed defect (duplicate)

Page does not reloads automatically when ABP 'Disable everywhere' option is deselected

Reported by: passbrains Assignee:
Priority: Unknown Milestone:
Module: Adblock-Plus-for-Internet-Explorer Keywords:
Cc: Blocked By:
Blocking: Platform: Internet Explorer
Ready: no Confidential: no
Tester: Verified working:
Review URL(s):

Description (last modified by sergz)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=AIN-81

Environment

Windows + Vista 64bit + Chrome + English
ABP version 1.3.0.0

How to reproduce

  1. Install latest ABP extension on IE.
  2. With ABP Enabled, Load website  http://filehippo.com/

3   Click on ABP icon and select "Disable on filehippo.com"
Observe reload icon near url bar. Observation 1

  1. Click on ABP icon again and deselect "Disable on filehippo.com" to deactivate it

Observe reload icon near url bar. Observation 2

  1. Click on ABP icon and select "Disable everywhere"

Observe reload icon near url bar. Observation 3

  1. Click on ABP icon again and deselect "Disable everywhere" to deactivate it

Observe reload icon near url bar. Observation 4

Observed behaviour

Observation 1 and Observation 2 : Page reloads on selecting/deselcting this option.
Whereas Page does not reloads When select/deselct for "Disable Everywhere". See Observation 3 and 4.

Internet explorer version :  9.0.8112.16421

Expected behaviour

Even when option "Disable everywhere" is unselected, page shall reload with ABP OFF.

Attachments (2)

3668_1419955733_hippo1.jpg (142.2 KB) - added by passbrains 4 years ago.
3668_1419955733_hippo2.jpg (126.9 KB) - added by passbrains 4 years ago.

Download all attachments as: .zip

Change History (6)

Changed 4 years ago by passbrains

Changed 4 years ago by passbrains

comment:1 Changed 4 years ago by sergz

  • Description modified (diff)

IE11 as well.
However screenshots don't contain anything regarding the issue.

comment:2 Changed 4 years ago by philll

Please clarify the expected outcome here as well as for #1146 and #1339, which is requesting the opposite behaviour. I remember that we once decided to never automatically reload, as this would unannouncedly mess with data entered into forms by the user.

comment:3 Changed 4 years ago by oleksandr

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1146. Also see #1339.

comment:4 Changed 4 years ago by oleksandr

  • Component changed from Unknown to Adblock-Plus-for-Internet-Explorer
Note: See TracTickets for help on using tickets.