Opened 5 years ago

Closed 5 years ago

#1751 closed defect (fixed)

"Block element" doesn't highlight (whole area of) elements if the background isn't (fully) visible

Reported by: passbrains Assignee: sebastian
Priority: P3 Milestone: Adblock-Plus-1.8.10-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: mapx Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working:
Review URL(s):

http://codereview.adblockplus.org/5598654983307264

Description (last modified by sebastian)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=ASA-32

Environment

Chrome, Opera, Safari

How to reproduce

  1. Install Adblock Plus extension in Safari 6.1.1 browser
  2. Load www.passbrains.com page
  3. Click ABP button
  4. Click Block element option
  5. Hover carousel element on the page and make sure only it is highlighted
  6. Observe main page content and see it becomes blank

Observed behaviour

The element .all-centered is blocked, but only parts of it were highlighted.

Expected behaviour

The whole element to be blocked should be highlighted.

Attachments (3)

2315_1420308685_2015-01-03_2009_1.png (591.7 KB) - added by passbrains 5 years ago.
2315_1420308819_2015-01-03_2009_2.png (184.3 KB) - added by passbrains 5 years ago.
2315_1420308819_2015-01-03_1855_block.swf (7.7 MB) - added by passbrains 5 years ago.

Download all attachments as: .zip

Change History (9)

Changed 5 years ago by passbrains

Changed 5 years ago by passbrains

Changed 5 years ago by passbrains

comment:1 Changed 5 years ago by mapx

  • Description modified (diff)

if you select only the slide with left/right sides and not the upper part above the slide you'll find the correct filter

www.passbrains.com##.new-banner

I tried this in chrome but I guess is the same for safari

Version 2, edited 5 years ago by mapx (previous) (next) (diff)

comment:2 Changed 5 years ago by mapx

  • Cc mapx added

comment:3 Changed 5 years ago by sebastian

  • Component changed from Unknown to Platform
  • Description modified (diff)
  • Owner set to sebastian
  • Platform changed from Safari to Unknown
  • Priority changed from Unknown to P3
  • Ready set
  • Summary changed from Blocking carousel on www.passbrains.com page blocks whole the page to "Block element" doesn't highlight (whole area of) elements if the background isn't (fully) visible

The problem is that the selected element is highlighted by changing it's background color and applying an inset shadow. Hence, the highlighting of elements whose background is covered by child elements, isn't (fully) visible. We should inject an overlay covering the element to highlight, instead.

Last edited 5 years ago by sebastian (previous) (diff)

comment:4 Changed 5 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:5 Changed 5 years ago by sebastian

  • Description modified (diff)

comment:6 Changed 5 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.