Opened 5 years ago

Closed 4 years ago

#1760 closed defect (incomplete)

ABP with root privileges prevents HTTPS

Reported by: xarx Assignee:
Priority: Unknown Milestone:
Module: Adblock-Plus-for-Android Keywords:
Cc: Blocked By:
Blocking: Platform: Android
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

LG D620R G2 mini with Android 4.4.2, rooted with TowelRoot application; ABP 1.2.1; SuperuserSU Free 2.40 used for granting root access to ABP.
Problem spotted with the built-in "Internet" browser, and also with the Google Play application.

How to reproduce

  1. Root your phone
  2. Install and configure ABP
  3. Allow root access for ABP in SuperuserSU (maybe a reboot is needed)
    1. Try accessing an HTTPS page (e.g. the Play store using the Play application) - server inaccessible
    2. Try accessing an HTTP page - works fine
  4. Prohibit root access for ABP in SuperuserSU (maybe a reboot is needed)
    1. Try accessing an HTTPS page - works fine
    2. Try accessing an HTTP page - works fine too

Observed behaviour

ABP works fine, until I grant it root privileges using SuperuserSU. After that (and after the phone reboot) all https connections stop working - including GooglePlay and https://www.google.com. When I prohibit root access for ABP and reboot again, HTTPS starts working again.

Expected behaviour

ABP in rooted mode should be able to serve both HTTP and HTTPS pages, as in non-rooted mode.

Change History (5)

comment:2 Changed 5 years ago by mapx

  • Component changed from Unknown to Adblock-Plus-for-Android

comment:3 Changed 4 years ago by xarx

I have resolved the problem - almost after a year :-).

The problem was caused by simultaneously allowing to ADP the root access AND at the same time leaving the wi-fi connection proxy directed to the ADP proxy (localhost:2020). After disabling the proxy in the wi-fi connection settings, HTTPS started to work.

comment:4 Changed 4 years ago by xarx

Please, close the ticket.

comment:5 Changed 4 years ago by mapx

  • Resolution set to incomplete
  • Status changed from new to closed
  • Tester set to Unknown
  • Verified working unset
Note: See TracTickets for help on using tickets.