Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#1773 closed defect (fixed)

[Typed objects] "assignment to undeclared variable bufferOffset" in unit tests

Reported by: trev Assignee: trev
Priority: P2 Milestone:
Module: Core Keywords:
Cc: Blocked By:
Blocking: #145 Platform: Firefox
Ready: yes Confidential: no
Tester: Verified working:
Review URL(s):

http://codereview.adblockplus.org/6155997320052736/

Description

Environment

Firefox 34, Chrome 39.

How to reproduce

  1. Run unit tests for typed objects.

Observed behaviour

"assignment to undeclared variable bufferOffset" error in Array memory allocation test - erroring out due to "use strict".

Expected behaviour

The tests succeed.

Change History (4)

comment:1 Changed 5 years ago by trev

  • Ready set

comment:2 Changed 5 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:3 Changed 5 years ago by trev

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:4 Changed 4 years ago by philll

  • Platform changed from Firefox/Firefox Mobile to Firefox

Made Firefox and Firefox mobile available as seperate platforms.

Note: See TracTickets for help on using tickets.