Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1774 closed defect (rejected)

adblock plus block my rest client extension

Reported by: skyfoxs Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: sebastian, mapx Blocked By:
Blocking: Platform: Chrome
Ready: no Confidential: no
Tester: Verified working:
Review URL(s):

Description

It block my rest client (Advanced rest client, Postman) extension and I cannot disable adblock plus or add whitelist for rest client
It annoy me that I have to disable it when I use rest client to test my localhost api server and have to switch on when I want to surfing the internet

Environment

Adblock plus 1.8.9 OSX 10.10.1 Google chrome 39.0.2171.95 (64-bit) with default filter EasyList

How to reproduce

  1. install Advanced Rest Client chrome extension
  2. open rest client on google chrome
  3. fill in URL with http://localhost:8082/api/ad/auth
  4. Use method POST
  5. fill in Payload as Raw data with

{

"username": "username",
"password": "password"

}

  1. set content type to application/json
  2. click send button

Observed behaviour

when inspect network with inspector request was blocked 'net::ERR_BLOCKED_BY_CLIENT'
and icon adblock plus show number incremental as how many click on send button

It still not working when add whitelist as localhost or 127.0.0.1

when disable extension in chrome extension rest client works properly

Expected behaviour

It should not block when whitelist added or it can be disabled for that specific extension

Change History (4)

comment:1 Changed 5 years ago by mapx

  • Cc sebastian mapx added
  • Component changed from Unknown to Platform

comment:2 Changed 5 years ago by mapx

Try adding this filter:
@@/api/ad/auth

comment:3 Changed 5 years ago by sebastian

  • Resolution set to rejected
  • Status changed from new to closed

This is the intended behavior. Since the URL entered here is http://localhost:8082/api/ad/auth it matches the filter /api/ad/* in EasyList, and gets blocked. You can whitelist that URL however, as pointed out above.

comment:4 Changed 5 years ago by skyfoxs

Thanks for answer

Note: See TracTickets for help on using tickets.