Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1802 closed defect (fixed)

Only first selector in multi-selector hiding rule works in Chrome

Reported by: Lain_13 Assignee: sebastian
Priority: P3 Milestone: Adblock-Plus-1.8.11-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: mapx Blocked By:
Blocking: Platform: Chrome
Ready: yes Confidential: no
Tester: Verified working:
Review URL(s):

http://codereview.adblockplus.org/5504296699297792

Description

Environment

OS: Windows 7 Ultimate SP1
Chrome: Version 39.0.2171.95 m
Adblock Plus: 1.8.9
Lists (doesn't matter): EasyList + RU Adlists + Anticounter and Bitblock from RU Adlist site.

How to reproduce

  1. Add filter issues.adblockplus.org###logo,#search
  2. Refresh this page.

Observed behaviour

Only logo in the top-left corner are hidden. In Firefox browser it works as expected.

Expected behaviour

Both logo in the top-left corner and search string with search button in the top-right corner have to disappear since multiple selectors divided with a comma is a valid selector as well.

Change History (8)

comment:1 Changed 5 years ago by mapx

  • Cc sebastian mapx added

comment:2 Changed 5 years ago by sebastian

  • Cc sebastian removed
  • Component changed from Unknown to Platform
  • Owner set to sebastian
  • Priority changed from Unknown to P3
  • Ready set

This is because we add ::content (to break out of the shadow DOM) only to the beginning of the CSS selector string. However, it needs to be added after every , (except those inside quotes) as well.

comment:3 Changed 5 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:4 Changed 5 years ago by sebastian

  • Blocking 1844 added

comment:5 Changed 5 years ago by sebastian

  • Blocking 1844 removed

comment:6 Changed 5 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:7 Changed 5 years ago by sebastian

  • Blocking 1853 added

comment:8 Changed 5 years ago by sebastian

  • Blocking 1853 removed
Note: See TracTickets for help on using tickets.