Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1803 closed change (fixed)

Do not use random email addresses in From: (eyeo.com contact form)

Reported by: trev Assignee: matze
Priority: P3 Milestone:
Module: Websites Keywords:
Cc: arthur, till Blocked By:
Blocking: #1753 Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working:
Review URL(s):

http://codereview.adblockplus.org/6094881009172480

Description

Background

eyeo.com contact form will send a mail according to the sitescripts/formmail/template/eyeo.mail template. This template currently puts the supplied sender's address into From: field of the email. This is problematic as we don't own the sender's domain and might be violating SPF policies.

What to change

Use From: donotreply@adblockplus.org and put the sender's address under Reply-To:.

Change History (7)

comment:1 Changed 5 years ago by matze

  • Owner set to matze

comment:2 Changed 5 years ago by matze

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:3 Changed 5 years ago by matze

  • Blocking 1753 added

comment:4 Changed 5 years ago by matze

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:6 Changed 5 years ago by trev

  • Cc arthur till added

Arthur notes that this breaks forwarding emails now - the forwarded email no longer has the address of the original sender. The way I see it, there is little we can do about this. Maybe forwarding in Gmail can be adjusted somehow to use Reply-To address? Otherwise people will have to add the original sender explicitly when forwarding mails.

comment:7 Changed 5 years ago by matze

We will look into this issue, of course. But in the context of a new ticket - this one here can remain closed (because it's an unpleasant side-effect of a mandatory change, not a bug with the change-set). Thus, please use the new ticket (#1946) for any further discussion. Thank you!

Note: See TracTickets for help on using tickets.