Opened 5 years ago

Last modified 4 years ago

#182 reopened defect

ABP for android breaks ebay.com sign-in.

Reported by: dvb Assignee:
Priority: P3 Milestone:
Module: Adblock-Plus-for-Android Keywords:
Cc: arthur Blocked By:
Blocking: Platform:
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

Description (last modified by philll)

Environment

Android 4.2.2, Pipo M7T or Hyundai T7S or I guess any other device. ABP 1.2, RuAdList+EasyList or only Easylist

How to reproduce

  1. Go to http://ebay.com and ensure the site to be displayed in "Desktop mode", such that there is no forward to http://m.ebay.com
  2. Click the signin link in the left upper corner
  3. Sign in
  4. Try to add any product to your watch list or tr to buy something

If you try to make any purchase ebay will send you to signin.ebay.com again.

  1. Only removing proxy setting in the connection helps successive sign in on Ebay.

Observed behaviour

Ebay will send you to signin.ebay.com again. Only disbaling ABP helps to stay successively signed in on Ebay.

Expected behaviour

Independent of the usage of ABP, the signed in state should not be changed compared to usage without ABP.

Change History (7)

comment:1 Changed 5 years ago by thesysde

Samsung Galaxy Note N10.1

The same, as above explained.
Add item to watchlist -> LOGIN -> LOGIN - LOGIN ......

comment:2 Changed 5 years ago by mapx

  • Priority changed from Unknown to P4

comment:3 Changed 5 years ago by philll

  • Resolution set to worksforme
  • Status changed from new to closed

Is your device rooted? Which browser did you use?

With a rooted Nexus 7 running ABP 1.2.1.323 (development version) and the Android stock Chrome browser, this works fine for me. Opening http://my.ebay.com redirects me to m.ebay.com with some sign in parameters. After signing in, i can perfectly watch/unwatch items or trying to buy them without signing in again.

If this still happens for you, please try the current development build and reopen this issue, if it still happens with that. You can get the dev build here.

comment:4 Changed 5 years ago by dvb

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I tried eBay Mobile (m.ebay.com) and signin works well there. But if I try to use Classic site (www.ebay.com), the issue is present. I tried latest ABP 1.2.1.323. By the way, it doesn't want to change subscription (well, it changes it, but then it's impossible to update it. Upon reeboot the subscription falls back to autodetected on first start). But that doesn't affect the current issue.

Anyway, my user agent string is "Mozilla/5.0 (Linux; U; Android 4.2.2; ru-ru; HYUNDAI T7S Build/JDQ39) AppleWebKit/534.30 (KHTML, like Gecko) Version/4.0 Safari/534.30", if that matters. I use standart android web browser. The device is rooted.

comment:5 Changed 5 years ago by philll

  • Cc arthur added
  • Description modified (diff)
  • Priority changed from P4 to P3
  • Ready set

@Arthur, could you please check for filter issues here?

comment:6 Changed 5 years ago by arthur

I think we need to wait for #416 to fix this. :(

comment:7 Changed 4 years ago by dvb

Any hope for fixing this?

Note: See TracTickets for help on using tickets.