Opened 5 years ago

Closed 5 years ago

#1820 closed defect (fixed)

ABP switching to a different tab leaves the original tab highlighted

Reported by: trev Assignee: sebastian
Priority: P1 Milestone: Adblock-Plus-1.8.10-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: sebastian Blocked By:
Blocking: #1742 Platform: Chrome
Ready: yes Confidential: no
Tester: Verified working:
Review URL(s):

http://codereview.adblockplus.org/5981059543990272

Description

Environment

Chrome 39

How to reproduce

  1. Open Adblock Plus options
  2. Switch to a different tab
  3. Click ABP icon and select Options

Observed behaviour

Both tabs are highlighted. This is a regression from #1742. Looks like using chrome.tabs.highlight() instead of chrome.tabs.update() will solve this issue.

Expected behaviour

Only the options tab is highlighted.

Change History (3)

comment:1 Changed 5 years ago by sebastian

  • Owner set to sebastian

comment:2 Changed 5 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:3 Changed 5 years ago by sebastian

  • Milestone set to Adblock-Plus-1.8.10-for-Chrome-Opera-Safari
  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.