Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#185 closed defect (rejected)

[seamonkey] ABP icon is added to bookmark bar after installation

Reported by: philll Assignee: saroyanm
Priority: P3 Milestone:
Module: Unknown Keywords:
Cc: trev Blocked By:
Blocking: Platform:
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/6287675942240256/

Description

Environment

Win 7 Enterprise
Seamonkey 2.25
ABP 2.5.1

Taken from https://adblockplus.org/forum/viewtopic.php?f=11&t=20587#p90806

How to reproduce

  1. Freshly install ABP to Seamonkey

Observed behaviour

The ABP icon appears in the bookmark and status bar.

Expected behaviour

The ABP icon should appear in the tool and status bar.

Change History (7)

comment:1 Changed 6 years ago by philll

See also #186.

comment:2 Changed 6 years ago by philll

  • Ready set

comment:3 Changed 6 years ago by saroyanm

  • Owner set to saroyanm

comment:4 Changed 6 years ago by saroyanm

After fix of this issue, we should ask people who still will see ABP icon in bookmarks bar to deal with corrupted profile:
http://kb.mozillazine.org/Corrupt_localstore.rdf
Steps to fix:

  1. Start SeaMonkey in safe mode ( http://kb.mozillazine.org/Safe_Mode#Starting_Safe_Mode )
  2. Check "Reset toolbars and window sizes" checkbox
  3. Click "Make Changes and Restart".

While we are storing information about ABP Icon possition in localstore.rdf using Persistent Data:
https://developer.mozilla.org/en-US/docs/Mozilla/Tech/XUL/Tutorial/Persistent_Data

We should ask users to go through current procedure, anyway It's only about users who have ABP installed.

Another option could be to delete the Persistent_Data on Cache or History Clear operation (have listener that will clear Persistent Data), or to delete it when the ABP is removed.

Anyway in that cases we should also think about if we store data that also need to be deleted on - Cache, History purge or on Addon Remove (maybe in that case that would be separate issue).

Last edited 6 years ago by saroyanm (previous) (diff)

comment:5 Changed 6 years ago by saroyanm

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:6 Changed 6 years ago by trev

  • Cc trev added
  • Resolution set to rejected
  • Status changed from reviewing to closed

The reason for having the icon in the bookmarks bar by default is styling. SeaMonkey comes with two themes by default: Default theme and Modern theme (yes, it was indeed modern around year 2000 when this theme was created). There is no way to ensure that our icon looks somewhat okayish in the toolbar for both. Placing the icon in the bookmarks bar is the only way to ensure it doesn't look horribly out of place in SeaMonkey. Whoever can live with the broken visuals can still move it over.

comment:7 Changed 6 years ago by saroyanm

Thanks for describing that Wladimir,
(Just noticed that the issue is closed)
Also closed the Review.

Last edited 6 years ago by saroyanm (previous) (diff)
Note: See TracTickets for help on using tickets.