Opened 5 years ago

Closed 5 years ago

#1857 closed defect (fixed)

Overlays are sometimes covered by elements with same z-index

Reported by: sebastian Assignee: sebastian
Priority: P3 Milestone: Adblock-Plus-1.8.11-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working:
Review URL(s):

http://codereview.adblockplus.org/6332642748268544

Description

How to reproduce

  1. Go to https://google.com/
  2. Click ABP icon
  3. Choose "Block element"
  4. Move pointer over search input field

Observed behaviour

Nothing is highlighted. However, there an overlay has been injected into the page which is correctly positioned where the text input is, but since it uses the same z-index it not visible.

Expected behaviour

The input field under the pointer should be highlighted. Therfore the overlay must use a z-index one higher than the element it was created for.

Change History (3)

comment:1 Changed 5 years ago by sebastian

For reference, previous bugs related to z-index calculation: #1607, #1755

comment:2 Changed 5 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing
  • Summary changed from "Block element" still injects overlays with too low z-index sometimes to Overlays are sometimes covered by elements with same z-index

comment:3 Changed 5 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.