Opened 6 years ago

Closed 6 years ago

#186 closed defect (fixed)

[seamonkey] disabled ABP icon in tool bar re-appears after seamonkey restart

Reported by: philll Assignee: saroyanm
Priority: P2 Milestone: Adblock-Plus-2.6.1-for-Firefox
Module: Adblock-Plus-for-Firefox Keywords:
Cc: Blocked By:
Blocking: Platform:
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5040954746601472/

Description

Environment

Win 7 Enterprise
Seamonkey 2.25
ABP 2.5.1

Taken from https://adblockplus.org/forum/viewtopic.php?f=11&t=20587#p90771

How to reproduce

  1. Rightclick the ABP icon
  2. Ensure "Options/Show in toolbar" is not checked
  3. Restart Seamonkey

Observed behaviour

The ABP icon formerly disabled reappears.

Expected behaviour

The ABP icon disabled should not reappear.

Change History (7)

comment:1 Changed 6 years ago by philll

See also #185.

comment:2 Changed 6 years ago by philll

  • Priority changed from P3 to P2

comment:3 Changed 6 years ago by philll

  • Ready set

comment:4 Changed 6 years ago by saroyanm

  • Owner set to saroyanm

comment:5 Changed 6 years ago by saroyanm

Seams like when the ABP icon is being removed from toolbar, the icon is not being removed fully, but placed under BrowserToolbarPalette for seamonkey.
So the toolbox.ownerDocument.getElementById("abp-toolbarbutton"); does not return null when the button is not being shown:
https://hg.adblockplus.org/adblockplus/file/d76e8603bcb9/lib/customizableUI.js#l182

And basically that is cause an error which prevent button of reappearing when the browser is being restarted while the correct state of the icon is not being saved during toolbox.ownerDocument.persist method call.

comment:6 Changed 6 years ago by saroyanm

Strange, I can't find BrowserToolbarPalette with DOM inspector while seams that it should be under "addon-bar" -> http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser.xul#1000
Anyway in FF it's looks like that BrowserToolbarPalette is somehow hidden from toolbox while in SeaMonkey it's in toolbox and seams that it's a reason behind the issue.

comment:7 Changed 6 years ago by trev

  • Component changed from Unknown to Adblock-Plus-for-Firefox
  • Milestone set to Adblock-Plus-for-Firefox-next
  • Resolution set to fixed
  • Review URL(s) modified (diff)
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.