Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1866 closed defect (incomplete)

ABP 1.8.10 'Block Element' right-click menu not working on facebook

Reported by: mapx Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: sebastian Blocked By:
Blocking: Platform: Chrome
Ready: no Confidential: no
Tester: Verified working:
Review URL(s):

Description (last modified by mapx)

Environment

windows 7
chrome 40
ABP 1.8.10 or the last 1.8.10.1326

How to reproduce

go to facebook.com
right click on an image
the option "block element" is not present in the context menu

reported in the forum: https://adblockplus.org/forum/viewtopic.php?f=10&t=27649

Change History (6)

comment:1 Changed 5 years ago by mapx

  • Description modified (diff)

comment:2 Changed 5 years ago by sebastian

I don't have a Facebook account, but at least on the logged out http://facebook.com/ page, the "Block element" context menu item is shown for images.

It looks like that the OP of that forum thread didn't right-click an image but a container element, we never showed the context menu item for. You have to use "Block element" from the icon popup to block those.

comment:3 Changed 5 years ago by mapx

In that case (of OP) is true: he wants to hide some html element (an entire zone) not only an image.
I tried blocking only an image and does not work (the option in the context menu is not present).
When I click the image (to open it) then on the opened image the option will be present.

Last edited 5 years ago by mapx (previous) (diff)

comment:4 Changed 5 years ago by mapx

I had an old test FB stuff (saved by some user), and you can see there, right click on the images in the page (scroll down) does not show the block element option

http://axistrivia.altervista.org/fb/fb.htm

Last edited 5 years ago by mapx (previous) (diff)

comment:5 Changed 5 years ago by sebastian

  • Resolution set to invalid
  • Status changed from new to closed

They use an interesting trick to hide images from the mouse pointer, applying following CSS on the image's parent element:

._4-eo::after {
border: 1px solid rgba(0, 0, 0, .1);
bottom: 0;
content: '';
left: 0;
position: absolute;
right: 0;
top: 0;
}

This essentially means that the image will be covered by an invisible pseudo-element. Hence mouse events will be dispatched to the image's parent element instead. Note that not only our "Block element" context menu item is missing, but also the built-in "Save image as" and "Copy Image URL" items.

comment:6 Changed 5 years ago by mapx

yep, right, "save image as.." is missing, I noted as well ... so, it's normal behaviour. Thanks.

Note: See TracTickets for help on using tickets.