Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1867 closed defect (fixed)

"Block element" dialog doesn't show if top level frame is a frameset

Reported by: sebastian Assignee: sebastian
Priority: P3 Milestone: Adblock-Plus-1.8.11-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: Blocked By:
Blocking: #1870 Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working:
Review URL(s):

http://codereview.adblockplus.org/5089087581061120

Description

How to reproduce

  1. Go to http://thewml.org/example/demo/
  2. Click the ABP icon
  3. Choose "Block element"
  4. Click the only image on the page

Observed behaviour

The image gets highlighted but the dialog doesn't show up. That is because it is injected as <iframe> into document.body in the top-level frame. However, the top level-frame is a frameset, hence document.body is a <frameset> element which cannot have <iframe> child elements.

Expected behaviour

The dialog should show up, when an element to be blocked is selected.

Change History (4)

comment:1 Changed 5 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 5 years ago by sebastian

  • Blocking 1870 added

comment:3 Changed 5 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:4 Changed 5 years ago by sebastian

  • Summary changed from "Block elment" dialog doesn't show if top level frame is a frameset to "Block element" dialog doesn't show if top level frame is a frameset
Note: See TracTickets for help on using tickets.