Opened 6 years ago

Closed 6 years ago

#187 closed defect (duplicate)

Adblock Plus for Chrome extension conflicting with Hangouts

Reported by: jameschao Assignee:
Priority: P2 Milestone:
Module: Core Keywords:
Cc: Blocked By:
Blocking: Platform:
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

On Google Chrome 35.0.1897.8 dev.
On OS X 10.9.2.

Replace this text with the Version of your operating system, your exact browser version, the used Adblock Plus version and the enabled Filter lists.

How to reproduce

  1. Create new profile (per [list=]listthe steps in the Google support page).
  2. Install Hangouts extension (https://chrome.google.com/webstore/deta ... hapd?hl=en).
  3. Open the Hangouts extension and sign in => see that everything loads properly)
  4. Close the Hangouts window.
  5. Install the ADP extension (https://chrome.google.com/webstore/deta ... fddb?hl=en)
  6. Open the Hangouts extension => see that assets no longer load)
  7. Disable the ADP extension (on chrome://extensions/).
  8. Open the Hangouts extension => see that everything loads properly again)

Observed behaviour

Hangouts will open as a blank window.

Expected behaviour

Hangouts should display properly

Workaround

Whitelisting talkgadget.google.com will cause it to function properly again.

There are additional investigations done by @ricky in the forums: https://adblockplus.org/forum/viewtopic.php?f=11&t=22080&sid=e59dbb36bf5fd4ef1136e27d51df8d86

Change History (5)

comment:1 Changed 6 years ago by ricky

Just to clarify what I said a little bit, the cause of the issue seems to be that in the recent dev chrome builds, extension windows no longer define window.url (previously, window.url was a chrome:// URL). A bunch of adblock plus code seems to assume that window.url is defined. The function that crashed in this case was isFrameWhitelisted, but there may be more places in the code where undefined window.url might need to be handled.

comment:2 Changed 6 years ago by philll

  • Priority changed from Unknown to P2

comment:3 Changed 6 years ago by philll

  • Component changed from Extensions-for-Adblock-Plus to Core

comment:4 Changed 6 years ago by ricky

It looks like this issue may be a duplicate of ticket #178.

comment:5 Changed 6 years ago by trev

  • Resolution set to duplicate
  • Status changed from new to closed

Resolving as a duplicate of #178 based on ricky's investigation - thank you!

Note: See TracTickets for help on using tickets.