Opened 5 years ago

Closed 5 years ago

#1870 closed defect (fixed)

"Block element" doesn't block <frame> elements

Reported by: sebastian Assignee: sebastian
Priority: P3 Milestone: Adblock-Plus-1.8.11-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: Blocked By: #1867
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working:
Review URL(s):

http://codereview.adblockplus.org/5861467656028160

Description

How to reproduce

  1. Go to http://thewml.org/example/demo/
  2. Click ABP icon
  3. Choose "Block element"
  4. Click any frame

Observed behaviour

After #1867 has been fixed the frames are highlighted but clicking them doesn't bring up the dialog. That is because the click event is dispatched for element's inside the frame.

Expected behaviour

When clicking a <frame> the dialog should show up, suggesting to add a filter to block it. Therefore <frame> elements must be handled the same way as <iframe> elements, injecting an overlay for every blockale frame.

Change History (2)

comment:1 Changed 5 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 5 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.