Opened 6 years ago

Closed 6 years ago

#188 closed defect (incomplete)

Utils.yield is undefined

Reported by: greiner Assignee:
Priority: P2 Milestone:
Module: Platform Keywords:
Cc: trev Blocked By:
Blocking: Platform:
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

Chrome

How to reproduce

  1. Build Adblock Plus for Chrome and load the extension
  2. Inspect its background page

Observed behaviour

There's an error in the Console tab: "Uncaught TypeError: Object #<Object> has no method 'yield'"

Expected behaviour

No errors.

Additional information

The Utils module in the Firefox version does have a "yield" method but since it's not part of core, Chrome's Utils module does not have that method and therefore throws an error.

Change History (2)

comment:1 Changed 6 years ago by trev

Build Adblock Plus for Chrome and load the extension

Nope. The correct step is: "Update dependency on Adblock Plus for Firefox and then build Adblock Plus for Chrome" ;)

This is an API change from #117 that wasn't implemented in Chrome yet, it needs to be done next time we update the dependency on Adblock Plus for Firefox. This is a trivial change, Utils.yield() should do nothing on Chrome.

Feel free to implement this. However, there will be more changes once #153 lands, it probably makes sense to implement all of it in one batch.

comment:2 Changed 6 years ago by trev

  • Resolution set to invalid
  • Status changed from new to closed

Resolving as invalid, there is no bug here. I created #189 to implement the API changes.

Note: See TracTickets for help on using tickets.