Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#1898 closed defect (incomplete)

adblock blocking my search on firefox

Reported by: Mathilda Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: mapx, arthur Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Verified working:
Review URL(s):

Description

Environment

I am on the Firefox with ad blocker

How to reproduce

  1. Do a search on fire fox search box as cakes.
  2. Now you will get a yahoo result page.
  3. On the result page perform a search cakes in nj
  4. You will get the suggestion and you try to hover on that with your mouse it all vanishes, and this is happening only when i have adblocker

...

Observed behaviour

search suggestion option vanishes

Expected behaviour

do you only block ads or breaking everything what i wanted

Attachments (3)

yahoo.png (204.8 KB) - added by arthur 5 years ago.
Screen Shot 2015-01-30 at 11.24.30 AM.png (574.7 KB) - added by Mathilda 5 years ago.
Search suggestion visible - 1
Screen Shot 2015-01-30 at 11.24.45 AM.png (554.7 KB) - added by Mathilda 5 years ago.
As you hover it will vanish -- 2

Download all attachments as: .zip

Change History (11)

comment:1 Changed 5 years ago by mapx

What subscriptions are you using ?
FF version ?
ABP version ?
What suggestion are you talking about ? ("You will get the suggestion")

As this seems to be a filter issue, create a new topic (providing all the details above and answering my questions) in the "Filters for Adblock Plus" forum: https://adblockplus.org/forum/viewforum.php?f=2

comment:2 Changed 5 years ago by mapx

  • Cc mapx arthur added
  • Resolution set to invalid
  • Status changed from new to closed

comment:3 Changed 5 years ago by arthur

I couldn't reproduce it btw (see screenshot).

Changed 5 years ago by arthur

comment:4 Changed 5 years ago by Mathilda

What subscriptions are you using ? -- Latest ABP filters
FF version ? -- FF 35.0.1
ABP version ? -- 2.6.7
What suggestion are you talking about ? ("You will get the suggestion")

--search for cakes you will see search suggestions.
--Hover using mouse you will see it vanishing.

I would say test it with and without ABP you will see the difference.

Changed 5 years ago by Mathilda

Search suggestion visible - 1

Changed 5 years ago by Mathilda

As you hover it will vanish -- 2

comment:5 Changed 5 years ago by mapx

I can't reproduce your issue (and arthur too - arthur maintains easylist subscription).
Disable your other addons and re-test.

"Latest ABP filters" means nothing: click ABP icon, filter preferences, "filter subscriptions" tab, see what lists are enabled.

If even disabling the other addons still happens, reset firefox and reinstall ABP. Re-test.
how to reset FF: https://support.mozilla.org/kb/reset-firefox-easily-fix-most-problems

Last edited 5 years ago by mapx (previous) (diff)

comment:6 Changed 5 years ago by mapx

hmm, now I can reproduce the issue

comment:7 Changed 5 years ago by mapx

yep, it's a wrong filter, add this custom 1:

~images.search.yahoo.com,search.yahoo.com#@#div[id^="yui_"][class] > div > ul[class] > li[class]

Last edited 5 years ago by mapx (previous) (diff)

comment:8 Changed 4 years ago by philll

  • Platform changed from Firefox/Firefox Mobile to Firefox

Made Firefox and Firefox mobile available as seperate platforms.

Note: See TracTickets for help on using tickets.