Opened 4 years ago

Last modified 10 months ago

#1912 reopened defect

Ad counters in icon menu and icon are inconsistent in Maxthon 4.4.4.1100

Reported by: philll Assignee:
Priority: P3 Milestone:
Module: Unknown Keywords:
Cc: jobp, sven Blocked By:
Blocking: Platform: Maxthon
Ready: no Confidential: no
Tester: Verified working:
Review URL(s):

Description

Environment

Windows 7 64 bit
Maxthon 4.4.4.1100

How to reproduce

  1. With ABP, Easylist & Acceptable ads enabled, go to http://aajtak.intoday.in/

Observed behaviour

The counter in the icon menu next to "Block ads on this website shows "18". The counter at the ABP icon itself shows "9+" as shown in attachment:maxthon_444-1100_adcount-inconsistency.png

Expected behaviour

The actual total amount of blocked ads should be displayed consistently.

Attachments (1)

maxthon_444-1100_adcount-inconsistency.png (280.2 KB) - added by philll 4 years ago.

Download all attachments as: .zip

Change History (16)

Changed 4 years ago by philll

comment:1 Changed 4 years ago by jobp

Although agreeing with the arguments above, I'll close this issue. Maxthon has UI concerns about showing two numbers in the icon, it would become too big and too attention-grabbing.

comment:2 Changed 4 years ago by jobp

  • Resolution set to invalid
  • Status changed from new to closed

comment:3 Changed 4 years ago by philll

  • Cc trev added
  • Resolution invalid deleted
  • Status changed from closed to reopened

This renders the icon count almost completely useless and is a huge inconsistency to our other products. @trev: Would you accept this difference?

comment:4 Changed 4 years ago by trev

  • Cc sven added

I certainly agree with the attention-grabbing argument, that's the reason why I didn't want to implement that counter in the first place.

Does the exact number actually matter or do we merely need to show that Adblock Plus is doing something? If it is the latter, then the solution implemented by Maxthon seems fine to me, and even worth considering for the other products.

@sven: Any opinions?

comment:5 Changed 4 years ago by sven

They should implement it like we did on google chrome. The additional work shouldn't be too much. It includes:

  1. At least the number of blocked ads with two digits (3 digits are very uncommon)
  2. The "show number in icon" checkbox in the bubble ui

comment:6 Changed 4 years ago by philll

I don't see any reason, why there should be more limitations than those in Chrome. So no additional 2-digits restriction. We might agree with them on having the "show number in icon" setting disabled by default, if they feel, it's too attention-grabbing. However, seeing how many feature Maxthon browser actually hosts in its UI, I don't see how it would be attention-grabbing at all.

comment:7 Changed 4 years ago by jobp

I would say that the counter is showing the user that ABP is doing its job. I do not think that many users are interested in the actual amount of elements blocked.

Let's not forget that Maxthon is the browser, ABP a new (awesome) feature, not an extension. Therefore, it should be up to them how many digits they show in their browser.

comment:8 Changed 4 years ago by jobp

  • Priority changed from Unknown to P3

comment:9 Changed 4 years ago by jobp

Based on the discussion above, I want to close this issue now. Maxthon made a decision based on valid arguments to show "9+" instead of a double-digit number.

comment:10 Changed 4 years ago by jobp

  • Resolution set to worksforme
  • Status changed from reopened to closed

comment:11 Changed 4 years ago by philll

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I guess our UI/UX expert decided differently.

comment:12 Changed 4 years ago by sven

Correct.

comment:13 follow-up: Changed 4 years ago by jobp

I'm sorry, but I just don't see any argument here besides "Consistency" here that justifies us pushing for this. And I would even classify the consistency argument as rather weak. Anyways, if I'm the only one here, we'll leave it open, but I think we have much more important issues to focus on.

comment:14 in reply to: ↑ 13 Changed 4 years ago by sven

Replying to jobp:

but I think we have much more important issues to focus on.

Sorry to say that jobp but that's not the way how an issue works. Everything beyond this issue is handled in an other issue and shouldn't have an impact on what is discussed here, except it is directly related to this issue. The importance of an issue is handled in the priority state.

Replying to jobp:

I'm sorry, but I just don't see any argument here besides "Consistency" here that justifies us pushing for this. And I would even classify the consistency argument as rather weak.

It's about UX and our quality requirements.

  1. At the moment there is no opportunity to hide the "number in icon" badge.
  2. The badge itself is kind of useless if you've activated the malware protection, social media buttons removal and the tracking protection, because you will have +9 blocked items on nearly every site.
Last edited 4 years ago by sven (previous) (diff)

comment:15 Changed 10 months ago by fhd

  • Cc trev removed
Note: See TracTickets for help on using tickets.