Opened 5 years ago

Closed 5 years ago

#1936 closed defect (duplicate)

ABP settings for whitelisting overrides the manual user settings on webapge

Reported by: passbrains Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: Blocked By:
Blocking: Platform: Internet Explorer
Ready: no Confidential: no
Tester: Verified working:
Review URL(s):

Description (last modified by oleksandr)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=AIN-85

Environment

Windows + Vista 64bit + Chrome + English
ABP version 1.3.745.0

How to reproduce

  1. Install latest ABP extension on IE.
  1. Open the ABP settings page and add  *adage* in whitelisting.

see screenshot  for settings.

  1. Load website   http://adage.com/
  1. Check the ABP icon as disabled which is fine.
  1.  Click on ABP icon and unselect  "Disable on adage.com" to enable ABP on this site.
  1. Observe ABP is still disabled.
  1.  Check the same scenario on Chrome where ABP is enabled as expected after Step 5.

Observed behaviour

Step 6 :  Page automatically refreshes on unselecting "Disable on adage.com"  but still ABP  remains disabled.

On Chrome,  on manually enabling the ABP on a site, the conflicting rule  from whitelisting gets removed.

Expected behaviour

User action  shall override settings rule as happen in chrome.

Attachments (2)

3668_1422291750_adage1.jpg (137.7 KB) - added by passbrains 5 years ago.
3668_1422291750_adage-settings.jpg (117.8 KB) - added by passbrains 5 years ago.

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by passbrains

Changed 5 years ago by passbrains

comment:1 Changed 5 years ago by passbrains

1 - 04 Feb 2015 12:18:35 posted by Ross Green
Reproduced. Having a site in the whitelist than toggling the the "Disabled on X" setting via ABP menu does show that ABP is following the shitelist over the user's "Disable on X" setting.

comment:2 Changed 5 years ago by oleksandr

  • Description modified (diff)
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1104

Note: See TracTickets for help on using tickets.