Opened 4 years ago

Closed 4 years ago

#1939 closed defect (duplicate)

Whitelisted domains list/Manage list is case sensitive even though domain names are case insensitive.

Reported by: passbrains Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: Blocked By:
Blocking: Platform: Internet Explorer
Ready: no Confidential: no
Tester: Verified working:
Review URL(s):

Description (last modified by greiner)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=AIN-90

Environment

Windows + 8 64bit + Internet Explorer 11 + English
ABP version 1.3.745

How to reproduce

  1. Click ABP icon. Click settings.
  2. Click 'Manage'. Add any website for example www.ndtv.com
  3. Add WWW.NDTV.COM
  4. Observe the same address is now present in the list

Observed behaviour

The same domains are added to whitelisted domains list twice.

Expected behaviour

Domain names are case insensitive and same domain shall not be added to the list twice.

Attachments (1)

3766_1423041898_ieWhitelist.png (239.6 KB) - added by passbrains 4 years ago.

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by passbrains

comment:1 Changed 4 years ago by passbrains

1 - 04 Feb 2015 14:09:26 posted by Ross Green
Reproduced. It's not possible to add the same lower-case address twice as expected, but it is possible to add the same address twice if one has lower-case characters and another upper-case.

comment:2 Changed 4 years ago by greiner

  • Description modified (diff)
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1442

Note: See TracTickets for help on using tickets.