Opened 5 years ago

Closed 5 days ago

#1972 closed defect (worksforme)

Whitelisted domains list is case sensitive even though domain names are case insensitive.

Reported by: passbrains Assignee:
Priority: P4 Milestone:
Module: User-Interface Keywords:
Cc: greiner Blocked By:
Blocking: Platform: Maxthon
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by jobp)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=MAX-59

Environment

Windows + 8 64bit + Maxthon + English

How to reproduce

  1. Click ABP icon. Click 'Edit blocking rules'.
  2. Click 'Whitelisted domains'. Add any website for example www.ndtv.com
  3. Add WWW.NDTV.COM
  4. Observe the same address is now present in the list.

Observed behaviour

The same domains are added to whitelisted domains list twice.

Expected behaviour

Domain names are case insensitive and same domain shall not be added to the list twice.

Attachments (1)

3766_1423230084_maxWhitelist.png (228.8 KB) - added by passbrains 5 years ago.

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by passbrains

comment:1 Changed 5 years ago by passbrains

1 - 06 Feb 2015 15:11:17 posted by Ross Green
Reproduced.

Also affects IE as per the other bug:
https://issues.adblockplus.org/ticket/1939

comment:2 Changed 5 years ago by jobp

  • Description modified (diff)
  • Priority changed from Unknown to P4

comment:3 Changed 5 days ago by greiner

  • Cc greiner added
  • Component changed from Unknown to User-Interface
  • Resolution set to worksforme
  • Status changed from new to closed
  • Tester set to Unknown
  • Verified working unset

I was unable to reproduce this issue using Adblock Plus 3.6.3.2413.

Note: See TracTickets for help on using tickets.