Opened 5 years ago

Closed 5 years ago

#1983 closed defect (fixed)

Whitelisting the current page and reloading it has no effect

Reported by: mapx Assignee: sebastian
Priority: P2 Milestone: Adblock-Plus-1.8.11-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: sebastian Blocked By:
Blocking: Platform: Chrome
Ready: yes Confidential: no
Tester: Verified working:
Review URL(s):

http://codereview.adblockplus.org/5943816674607104

Description (last modified by sebastian)

Environment

ABP 1.8.10.1341
easylist

How to reproduce

go to http://www.yelp.com/biz_photos/suite-1901-cheyenne?select=xXB75PlplCa9dh-ETku9Ig#xXB75PlplCa9dh-ETku9Ig

Disable ABP for yelp.com (the site will be in the whitelisted domains list)

Refresh the page ==> the ads are still blocked (and the ads number is still on ABP icon)

Change History (4)

comment:1 Changed 5 years ago by sebastian

  • Owner set to sebastian
  • Priority changed from Unknown to P2
  • Ready set

This regression were introduced by #1976, and is currently only visible in the devbuild.

comment:2 Changed 5 years ago by sebastian

  • Description modified (diff)
  • Summary changed from Disable ABP ==> no effect on some pages to Whitelisting the current page and reloading it has no effect

Whilst fixing a memory leak caused by pre-rendered pages (#1976), I also fixed a similar issue triggered by navigation, where the frame hierarchy of the previous page were leaked. But now ext.pages.onLoading is triggered before those data are removed. Hence at the time the listener is called, it still thinks that we are on the previous page.

comment:3 Changed 5 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:4 Changed 5 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.