Opened 5 years ago

Closed 2 years ago

#2011 closed defect (duplicate)

CSS syntax of filter is not validated like Chrome

Reported by: passbrains Assignee:
Priority: Unknown Milestone:
Module: Adblock-Plus-for-Firefox Keywords:
Cc: Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by sebastian)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=ARE-77

Environment

Windows + 8 64bit + Firefox + English
ABP version 2.6.7.3896

How to reproduce

Refer MAX-55 ticket.
Filter rule is 
indiatimes.com##div[style="float:left;font-size:20px;font-weight:normal;font-family:georgia;padding:10px;"]
Add this filter without first quotes for ex: 
indiatimes.com##div[style=float:left;font-size:20px;font-weight:normal;font-family:georgia;padding:10px;"]
Chrome displays filter rule "is not a valid CSS selector".

Observed behaviour

Firefox accepts filter without any error.

Expected behaviour

Firefox should display filter rule "is not a valid CSS selector".

Attachments (2)

3766_1423841886_firefoxCss.png (170.2 KB) - added by passbrains 5 years ago.
3766_1423841886_chromeCss.png (198.3 KB) - added by passbrains 5 years ago.

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by passbrains

Changed 5 years ago by passbrains

comment:1 Changed 5 years ago by passbrains

1 - 18 Feb 2015 07:12:19 posted by Ross Green
Reproduced, however not sure if this is currently a bug or not. Am currently asking around.

2 - 18 Feb 2015 14:37:29 posted by Ross Green
There is already a Maxthon version of this bug in Trac so I'm confirming this one for Firefox.

comment:2 Changed 5 years ago by philll

  • Platform changed from Firefox/Firefox Mobile to Firefox

Made Firefox and Firefox mobile available as seperate platforms.

comment:3 Changed 2 years ago by sebastian

  • Component changed from Unknown to Adblock-Plus-for-Firefox
  • Description modified (diff)
  • Resolution set to duplicate
  • Status changed from new to closed
  • Tester set to Unknown
  • Verified working unset

Duplicate of #493.

Note: See TracTickets for help on using tickets.