Opened 5 years ago

Closed 4 years ago

#2016 closed defect (invalid)

Cannot interact with dialog opened by Facebook Like button on share.adblockplus.org

Reported by: passbrains Assignee:
Priority: P3 Milestone:
Module: Websites Keywords:
Cc: Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by greiner)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=ARE-76

Environment

Windows + 8 64bit + Firefox + English
ABP version 2.6.7.3896

How to reproduce

  1. Go to https://share.adblockplus.org/en/
  2. Click on Facebook Like button

Observed behaviour

'You like Adblock plus' dialog box pops up and closed. Again 'Confirm' button needs to be pressed. Then 'Confirm Like' dialog box is opened.

Expected behaviour

'Confirm Like' dialog box is opened without flickering due to opening and closing of another dialog box and without need of clicking 'Confirm' button.

Attachments (1)

3766_1423819668_firefoxFacebook2.mp4 (858.3 KB) - added by passbrains 5 years ago.

Download all attachments as: .zip

Change History (7)

Changed 5 years ago by passbrains

comment:1 Changed 5 years ago by passbrains

1 - 18 Feb 2015 07:11:45 posted by Ross Green
Having trouble getting a FB account to test with currently...

2 - 19 Feb 2015 09:13:19 posted by Ross Green
Reproduced.

Have not been able to figure out why the confirm dialog appears and disappears so quickly after a like. Agree it doesn't look great.

comment:2 Changed 5 years ago by greiner

  • Component changed from Unknown to Websites
  • Description modified (diff)
  • Owner set to saroyanm
  • Summary changed from On first run page, when clicked on facebook icon, then Like button, a dialog box is opened and closed. to Cannot interact with dialog opened by Facebook Like button on share.adblockplus.org

We're using the official Facebook Like button widget on this page so this may be an issue with that widget and not with any of our code.

comment:3 Changed 5 years ago by greiner

  • Owner saroyanm deleted

Not sure why it automatically set the owner field so I unset it again.

comment:4 Changed 5 years ago by saroyanm

  • Priority changed from Unknown to P3
  • Ready set

comment:5 Changed 5 years ago by philll

  • Platform changed from Firefox/Firefox Mobile to Firefox

Made Firefox and Firefox mobile available as seperate platforms.

comment:6 Changed 4 years ago by greiner

  • Resolution set to invalid
  • Status changed from new to closed
  • Tester set to Unknown
  • Verified working unset

This issue also occurs when embedding the Like button on an empty page under a different domain. Therefore closing this ticket since it appears to be an issue with the button itself and not with the share page.

Note: See TracTickets for help on using tickets.