Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#2027 closed defect (rejected)

Unable to Download Files in UC Browser with ABP Proxy config

Reported by: Xi Assignee: rjeschke
Priority: Unknown Milestone:
Module: Adblock-Plus-for-Android Keywords:
Cc: Blocked By:
Blocking: Platform: Android
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

OS: Android v4.0.4 and various handsets tested with OS versions starting from v4.x.

Browser: "UC Browser" most versions from v9.9.6.495 to v10.2.0.535[latest]

ABP version: Affected - Adblock Plus most versions from v1.2.0.317[stable], v1.2.1.319[stable] through v1.2.1.355[latest build]

Proxy Details:
localhost
port:2020

Filter Lists: EasyList

How to reproduce

Description:
Many have reported the issue while downloading using UC Browser with ABP for Android Proxy on a WiFi Network. The file doesn't download when the proxy is configured. However, when the proxy is set to None, the same file download is successful. Downloading using Mobile data is also successful.

Here is the sample download which was experienced by one of my friends.

  1. Go to https://www.torrapk.com/
  2. Click on any of the apps listed.
  3. Scroll down the page and Click on "Download the apk file-TorrApk".
  4. In the next page, scroll down the page and click on "Download" button.
  5. When asked for Download option, Click on "Download".

Observed behaviour

The download is about to start but says "Not connected, connecting" and goes on Retrying(1),(2),....

When checked the Details of the Download, it is mentioned:
Error Code:de500
Error Info: Unknown Error.

Expected behaviour

The file should start downloading in the first stance and the download has to be successful.

This downloading issue is also experienced in various other sites.
The same issue is experienced occasionally earlier. However, currently this issue showed up again in the last few months.

Firefox for Android is not affected and the downloads work well with ABP Proxy Settings configured.

Change History (6)

comment:1 Changed 5 years ago by mapx

  • Component changed from Unknown to Adblock-Plus-for-Android
  • Owner set to rjeschke

comment:2 Changed 4 years ago by Xi

Additional Information:

With ABP Proxy configured, the issue is mostly with HTTPS download links.

HTTP downloads are not affected. They were successful with ABP Proxy configured.

Last edited 4 years ago by Xi (previous) (diff)

comment:3 Changed 4 years ago by j123b567

I have the same problem

With ABP proxy set (it don't mind if ABP is enabled or not)

  • I can't login to https://tumblr.com
  • I can't post images
  • I can view page, if I was already logged in before setting ABP proxy

Problem can be solved only by unsetting the proxy

This problem is in

  • LG Fino with Android 4.4.2 - no root
  • Google Chrome 40.0.2214.109
  • Tumblr app 3.8.1.01
  • ShortBlogger Pro for Tumblr app 2.0.7

All HTTP trafic is ok. It only affects some HTTPS.

Tested with

  • ABP 1.2.1
  • ABP 1.2.1.354

comment:4 Changed 4 years ago by Iananan

Still having this problem in abp for android 1.3 #359 android 5.1 on moto x (2014) chrome 43.0.2357.93

I noticed it first with the tumblr app, but have actually just had to disable the filter to register for this issue tracker, as it was blocking the https traffic there too. Makes it a choice between secure connections with ads, or no ads and half the internet gone.

comment:5 Changed 4 years ago by rjeschke

  • Verified working unset

This problem is not caused by us, it is caused by the apps you mentioned.

The thing is, issuing a https request through a http proxy is done via CONNECT, this is called SSL tunneling. UC Browser fails to detect the existence of a proxy server and tries to do an https request via GET over an http proxy, which can and should not work.

So, please file this as a bug report to the guys from UC Browser, tumblr will possibly be the same, but I try to look into this now.

Last edited 4 years ago by rjeschke (previous) (diff)

comment:6 Changed 4 years ago by rjeschke

  • Ready set
  • Resolution set to rejected
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.